New patch for 6/16/2020 broke launcher

This new patch you guys just pushed out today has broke the launcher. Now every time I try to update it gives me an error I even tried everything on the support page that it says to do when that happens. Still nothing.


One thing to try, if you aren’t already, is to run it in administrator mode. Close it down completely, then right click the launcher icon and select “Run as Administrator”.

1 Like

Have you tried the steps here: Known Technical Support Issues - Updated July 21, 2020 - #13 by Drakuloth ?

It fixed it for me!

Yet again a battlenet update today has caused problems. I had managed to just about fix all the issues and here we go again, game is broken. I’ve been through this so many times that I’m considering the option of sadly unsubbing for real because I can’t keep on paying for something that breaks on every patch. It seems like there are inherent problems that are just not being fixed from patch to patch - I find myself questioning the skills of the people tasked with preparing patches for download - are they under pressure to release the patch and not taking into account problems with previous patches? I always run in administrator mode and I don’t have voice proxy in my running processes.

Same thing here OP. Can’t update the game.

Nothing changed for me. “Something went wrong with a file. We’re not sure what happeneed, so please try again, or follow these steps.” (The steps listed didn’t work.)

This worked!

(Open Task manager, End Task on World of Warcraft Voice Proxy.)

1 Like

Thank you! That worked for me too!!!