Naglering not working correctly

When being attacked while Naglering is equipped on character, no arcane damage proc is occuring.

Binds when picked up


50 Armor
+10 Stamina
Requires Level 54

Equip: When struck in combat inflicts 3 Arcane damage to the attacker.
Equip: Increased Defense +5.


Might be related to this?

Tl;dr, some item effects are auras that were not being applied correctly or being overwritten by other buffs.

I saw another person posting about naglering not working as well and he was also a druid. I wonder if it’s conflicting with Thorns? Try removing thorns from your character and then unequipping and equipping naglering again and see if it works. I saw some one else post in the other thread saying it worked fine but he wasn’t a druid so maybe that’s where the bug comes from.

In any case, if it’s related to the issue I linked, it sounds like blizz has a fix on the way.

Just tried your experiment, no thorns buff with ring equipped no success, still not working.

Edit*: correction seems to be dealing damage, but not showing up on scrolling combat text, or the combat log. So it appears to be working but the damage is not associated with any source. Probably not getting threat from the damage if this is the case.


Shame. Well, it sounds like it could be related to the issue the blue post was describing regarding equipment effects. Maybe it will get resolved when they push out the fix for that. Hopefully blizz will post when they push that fix through and then you can test it out again. If it’s still broken then you should bump the thread. It’s a bug for sure.