macOS 10.13.6 Not Supported

Just recently got back into WoW, so I’ve been playing recently with no problems util today. I tried logging on but a pop-up saying - “macOS 10.13.6 Not Supported”, basically stating that the operating system will no longer run Shadowlands.

I am on an older Macbook Pro, am I just out of luck or is there a work around?

Minimum requirements for the OS version on the website are listed as 10.12, with 10.14 being recommended. Either there’s a way to get it to work, or that information is outdated. If there’s a way to get it to run on that version of the OS, I’m not sure what it is. I’m sure someone else does though.

Some things I would try would be to run all of the updates for the OS. That’ll make sure all of your drivers are up to date, which might be what’s actually triggering the error.

Another possibility is that, while the version of the OS you’re running is supported, the hardware inside your MBP is the actual problem. They don’t list model or year cutoffs on the system requirements page ( ), but it sounds like the integrated graphics might either be just on the edge of supported, or could be outside of system requirements. Hard to say without more info.

I recently got a similar message on one of my Macs, although, it gives you two options, one to quit the WoW app, and the other to continue anyways.

If you have the same two options, click continue anyways to play on the older OS.

This is just an “end of life” warning that the minimum requirements are going to be changing soon for WoW, and it is recommending that you update your OS.

It doesn’t give a time frame for when the OS will no longer work, but IIRC, it usually happens with the new expansion pre-patch.

Usually, yes. But not always. 10.12.6 was working until July 1st, when the WoW patch that day abruptly cut it off. This was almost certainly due to Blizzard using the most up to date XCode in order to support the latest Macs properly. There is the potential for 10.13.6 to also be cut off if Apple decides to be douchebags and make XCode not target 10.13.6 before WoW 10.0 launches.

I’m still on 10.13.6 because I can’t go further, being that I have a GTX 1080 Ti for my GPU. I want one of the new AMD 6900XTs, but I can’t find it for any reasonable price or I’d get it so I could update to Big Sur and be done with the OS hassle for another two or three years.

You can do something to mitigate the OS nag slightly. Open Terminal, then copy and paste the following line into it and hit Enter:

defaults write com.blizzard.worldofwarcraft DisableOSVersionCheck YES

You will still get the OS nag once, and continue to see the ! triangle on the character select screen letting you “know” your graphics drivers are out of date (duh), but you should no longer get the popup on starting WoW. This will only allow WoW to work for you as long as the version of XCode Blizzard is forced to use also allows targeting 10.13.6 as a minimum OS. Our days on that OS are numbered, unfortunately.


It’s interesting that you saw this a month ago. I am also on 10.13.6 and only just saw this message today. Oddly, it recommends upgrading to 10.15, even though 10.14 is still supported under their “current major release plus last two” scheme, so 10.14 would be an option, and 10.15 is not the latest, so if you’re going for not the minimum, why not recommend the latest? Very weird.

I am currently in the same boat, where I cannot move past 10.13.6 until I find a different video card (I actually also have the GTX 1080 Ti). I would prefer not to move past Mojave due to lack of 32-bit support after that, but if they’re really going to blackball Mojave when Monterey comes out, who knows. I am planning to get an M1 mini and run WoW on that, keeping my existing setup for Steam and Bootcamp.

Anyway, thanks for the defaults tip!

12.0 is a month away, that’ll make 10.14 fall off under “plus last two”. they are probably getting ahead of it now.

Soon it’s going to be 12.x, 11.x and 10.15

But i wouldn’t expect 10.14 to break so quickly. metal hasn’t changed too much since it. but 10.13 metal is way too old at this point. There is a reason just about every mac game ported by feral and aspyr lately is 10.14.6 or higher. 10.13 lacks certain apis that are being used by modern metal apps.

Recommendin 10.15 or higher is just probably for good measure, mostly at driver level because 10.14 drivers are feeling their age at this point, as apple still holds exclusive control over driver distribution on 10.14 and later, they ensure you don’t get bugfixes unless on latest and greatest only.