M1 Max = RTX 3080

I think Anandtech and Notebookcheck as well as HUB did test few native ones. In WoW M1 struggled with particle effects like any iGPU. M1 Max has much better memory bandwidth (and bigger iGPU) but still going M1 Max should be justified by something way better than WoW. Also laptop with 3080 are bit of a lye due to mobile part and their power constraints. Even mobile 3070 is a mixed value (and can have various TDPs from awful to somewhat acceptable).

On a small laptop screen even RTX 3060 or 1660Ti would be more than enough for WoW 1080/1440p even for faster screens assuming CPU is really good.

And to get GPU heavy scenario in WoW you would need a widefield view in Ardenweald or a lot of particle effects that happen in some boss encounters (I use a lot of mobs from old Karazan that constantly channel a flame spell).

Yea of course, this obviously can’t compete with my 3080 in my desktop. But for the performance it offers on the go in the package it’s in, I’m more than satisfied with it, hope wow continues to support Mac OS, it’s a big reason I’ve been subscribed for 11 years haha.

2 Likes

Thanks. This gives me great hope for the 27 inch (or larger) iMac models to come in 2022.

do you have suggestions for my optimal settings to achieve 60FPS or at least 50FPS stable while still having nice graphics settings?

I run a macbook pro 2017 15 inch 2.9ghz!

Thank you~!

So you have Radeon Pro 555 or Radeon Pro 560 which are bit better than modern typical iGPU (Vega 8/Xe G7). I would recommend running the game at 1080p resolution and mode 3 or 4. If you get stutter when mass spell effects go out on mode 4 then go to 3 or directl lower spell effects settings.

1 Like

Hi, are you using 32 or 24 core gpu version ? Thanks ^^

bit late to the reply, but 34 core

1 Like

Was the client just not optimized well for M1 Macs back in December? I bought a 16" MBP M1 Pro on NYE, and in a very densely packed Orgrimmar with settings set to 10 and everything cranked except shadows, and I pull about 84 FPS.

Cranking shadows tanks it, but I’d hardly call the M1 Pro unable to handle the game with ElvUI - which I use as well.

Similar levels of performance in SL areas as well…and yes this is at native resolution of the built in panel, 100% scale.

Hey, thanks for the detailed post. Ive never used macs fan control before. what sensor do you typically find the most useful to control? im watching cpu core average now. I feel like gpu makes sense, but the m1 has cpu and gpu integration, correct?

I use gpu core temp for monitoring and fan curve control.

1 Like

Thank you for this post. I am returning to the Mac after 3 years on an Alienware R9 with the RTX 2080Ti. I was concerned about how well I could run WoW on a Mac. Pushing the buy button on a Mac Studio today!

I just got my Mac Studio M1 Max (32-core GPU) last week and would like to add my experience on how it runs WoW. (warning: long post)

It’s a great machine so far. Major upgrade compared to my old 2017 iMac 5K. I’ve hooked it up to a LG 27GN950-B 144 Hz 4K gaming monitor (still also waiting for the Studio Display to be delivered). The cable I use is a USB-C to Displayport 1.4.

I play in native 4K (3840x2160) with most settings on High and Ultra but with Shadows and Liquid on “Fair”, Compute Effects on “Low” and SSAO on “Good”. Not using any anti-aliasing (looks sharp enough).

My FPS results are as follows:
Zereth Mortis: 130-144 FPS
Revendreth: 130-144 FPS
Maldraxxus: 90-130 FPS
Ardenweald: around 100-120 FPS with occasional dips to 70
Bastion: around 48-112 FPS

Oribos: upstairs on the flight master floor ± 48 FPS, the main floor fluctuates between 60 to 120 FPS.

Heart of the Forest: the center area indoors around 60 FPS but as soon as you enter another room it’s back to 130-140 again.

I do run quite a lot of addons, notably ATT (All The Things) and TRP (Total Roleplay) which are known to affect performance.

Now something about FSR, because it puzzles me a little. I’m playing in full 4K (3840x2160) as mentioned earlier, with resolution scale set to 100%. On the iMac (Radeon) I used to set it to 50% and FSR did the rest. However, on the Mac Studio FSR doesn’t seem to do anything. When I set res scale to 50%, it looks far more blurry. Turns out FSR is disabled by default, and enabling it doesn’t improve anything.

The Ambient Occlusion Type (Advanced tab) was set to ASSAO per default (instead of FSR), and the Resample Quality to Point (instead of FSR). However, when changing both to FSR I see no difference. Is FSR only a Radeon thing?

Oddly enough the Resample Sharpness slider is still enabled and on 0.2 (per default) but adjusting that doesn’t seem to change anything either. Nor does my FPS improve.

Anyway, I’m happy with how it runs, a huge upgrade for anyone coming from an Intel Mac.

(edit: changed Bastion performance. it was stuck at 48 FPS at first but seems a glitch, the other day it was 112 again. Depends on the area it seems)

Two things.

ASSAO versus AMD CACAO is not related to FSR. the CACAO is a fork of ASSAO by AMD that adds more effects and generally better performance on newer hardware.

FSR is any gpu and I use it exclusively on my M1 Max. The fact you can’t get it working is actually puzzling.

You’d definitely be able to squeeze more ultra settings easily if you can figure out why FSR isn’t working. It’s possible you have some other cvars disabled that it relies on. maybe you copied config from another mac or something? I’d be curious if you dump your config.wtf file and redid your settings again if you could get it to behave. Of course change resampling from point to FSR. You should be able to run ultra everything else easily except for compute which I’d honestly leave off. compute easilly chops up to 20-40fps off in zones like ardenweald for a little bit of extra volumetric fog/mist. it’s a very pricy setting with almost no gain similar to RTX on windows (you genuinely have to squint and zoom in to notice what RTX is doing yet it halves performance despite the fact in wow it’s only supported for only some lighting and shadows sources)

Thanks for your reply. I finally got FSR working correctly now! I did start out with a fresh .WTF. I guess something went glitchy after fiddling too much with the settings.

FPS in Oribos and Elysian Hold improved dramatically right away, without noticing any loss in quality. It’s working great now. Pfew!

1 Like

yep, I know what my max can do, your ultra should be able to do even better…

using FSR you should have almost no issue locking in great fps with everything on ultra (minus compute, that will still take large hits in ardenweald, mechagon, and a few other places making extreme heavy use of compute shaders)

I’d be curious about your new numbers

Hah, if only it was an Ultra - mine’s just a ‘pathetic’ Max 32 core… :wink:

I’m now getting 135-144 FPS in almost all Shadowlands zones with the settings you mentioned. That’s the max of the monitor (could maybe push it even higher when overclocking turned on on the monitor, but it’s good for now). Elysian Hold and upper Oribos are 80-110 FPS which is fine. FSR is on with the render slider on 72% (I know it’s an odd number, could possibly get even better results with it on 50%, but it’s fine for now).

Now my experience about monitors, for anyone coming from a retina iMac and considering a Mac Studio for general use and gaming (esp WoW) AND you would want to have some higher Hz.

Get at least a 4K (gaming) display, don’t bother with native 1440p. (most gaming displays for sale are 1440p native). Yes 4K is more expensive but if you’re coming from a retina screen, 1440p will not look pretty: text will look somewhat grainy, you can really see the pixels.

In WoW that means while the graphics itself look sharp, anything with text (quest text, Titanpanel currency, interface text etc) will look grainy (not blurry, just grainy).

That’s because 1) we’re spoiled with retina, 2) HiDPI font scaling on non-retina screens is quite bad in recent MacOS versions. Apple is not selling any non-retina screens any more, so HiDPI support on lesser screens has no more priority in recent MacOS, unlike Windows. That includes items with text in WoW.

I tested both an LG Ultragear 27GP850 (1440p native) and a 27GN950 (4K) and the difference was dramatic. Both are 27" 144 Hz gaming monitors. In the end I sent the 27GP850 back.

(Out of curiosity I connected the 27GP850 to my old 2017 iMac 27" 5K and was quite baffled: I got 100-120 FPS on average in most Shadowlands zones with slider on 7… quite hilarious on an intel Mac but I guess the Radeon never had to work hard at native 1440p)

So I finally have my Mac Studio as well (Ultra 48 cores gpu) no matter what I do I can’t reach the same level of performance as you have.

I tried the same resolution at 8/10 settings and while casually doing quests my FPS is around 50.

Well for one we don’t know your display, it could be a 5k display not 4k or lower, so if you’re trying to push that without appropriate render scale and AI upscaling it’ll be costly.

It’s Apple Studio Display

Yeah what I thought, that’s a 5k display. 4k is demanding enough. at 5k, you’re rendering at 1440p even at 50% render scale, which with your setup should still run ultra pretty good. I imagine you just haven’t properly setup using 50% render scale and fidelity super resolution upscaling settings yet.

3 Likes