Lua error when trying to save UI

Experiencing the same lua error beginning today. Neither new nor existing layouts can be saved. The workaround just doesn’t seem to stick for me, sadly.

1 Like

thanks man but i get the lua error even when i try to copy the profile, or even if i try to rename it. Lua error all the way

1 Like

Same here, started today. Cannot save changes or make new layouts. I posted the error code in the larger UI thread.

1 Like

Yeah it’s terrible.

It’s stopped working on my paladin now. So now I have to log onto an alt to try and make changes.

1 Like

Also having this issue. Can not even load other versions of the UI - even the default 2 - Can not delete any premade ones either. Every time i hit save i get a bunch of errors or nothing happens except my party frames jump downward for w.e reason -.- This was not an issue til today and ive did all the things as everyone else above to no avail.
Only work around I have found is an annoying time consuming one - I redid all my UI’s / Imported similar ones / alts of same class then messed around a bit with that, then hit save as a new ui and character specific… I copied and pasted all my load outs into note pad in case they got wonky again and i end up with party frames in my chat, my bars all out of wack, missing bars, or all my bars overlapping everywhere. Sometimes even the making new loadout w character specific selected gets wonky and either doesnt wanna save or reverts to w/e placement with w/e number of icons and messes up my bars completely even abilities wise -.-’’…

I cant even delete, edit, or change up any pre-existing ui and if i try to select even the 2 preset by the game itself also nothing. So for now I have like 4-5 diff character specific saves just because i realized i forgot to move something before making the new loadout since editing and deleting the other one isnt an option at all.

I to am having the same issues. I’ve removed all my addons, deleted the WTF, Interface, and Cashe directories, and still get the same lua error

Not sure if this was said already, I didn’t read through updates on the thread. I Just fixed the arithmetic on a nil value error by deleting these files. .

Go to WTF/Account and delete edit-mode-cache-account and .old. Also delete flagged-cahce-account and .old.

Go into each character folder on your server, and delete edit-mode-cache-character and flagged-cache-character.

Start over. It may only be the edit-mode-cache files only, dumping the flagged-cache files won’t hurt.

There is something else going on with party frames, it wants it to stay in the default location, but the LUA error is gone for me after doing this and deleting the files in the character folders makes it so I don’t have to go to alts.


That worked for me!

This did not work for me. :frowning: Same error and now all my layouts are gone with no way to put them back.
Edit: I imported the code from my old layout and it threw the error but did save. Still get the nil lua error for making new layouts and trying to save changed.

My fix to this was…

  1. Switch back to one of the preset profiles.
  2. Delete the custom one I already saved from there.
  3. While still in the chosen preset start to lay out your UI.
  4. Save your setup.
  • Hope this helps.

I found a work around. It seems the bug is with my default UI. I selected the new layout option from the dropdown in the HUD Edit Mode and it allowed me to save my changes.

Hope this helps others that are stuck.

1 Like

Easier workaround that I discovered: make sure Raid Frames and Boss Frames are toggled on during Edit Mode, and that you don’t have an addon hiding them, then /reload


Hi everyone, so I wanted to say that I found a solution to my problem, since i was having the same error today.
Usually i browse these things and never post, so here goes…

I was getting the LUA error, same as all of you, and none of the given answers helped, but i did find out that the issue I think stems from being on a different character then the original character when I made the custom HUD to begin with.

For example, on my new Dracthyr character I was getting the error trying to copy or save a new HUD from what i used on my priest. However, the HUD on my new character had a bunch of things turned off. Extra action bars and such, for example. When i enabled all that was originally missing from the Priest’s HUD, I was suddenly able to save/copy and generally make a new HUD for my new Dracthyr as desired.
Maybe this will help you guys?

Having a similar issue. Here is my bug report.

8x FrameXML/EditModeSystemTemplates.lua:468: attempt to perform arithmetic on a nil value
[string "@FrameXML/EditModeSystemTemplates.lua"]:468: in function `BreakFrameSnap'
[string "@FrameXML/EditModeSystemTemplates.lua"]:41: in function `PrepareForSave'
[string "@FrameXML/EditModeManager.lua"]:1118: in function `PrepareSystemsForSave'
[string "@FrameXML/EditModeManager.lua"]:1123: in function `SaveLayouts'
[string "@FrameXML/EditModeManager.lua"]:1132: in function <FrameXML/EditModeManager.lua:1128>
[string "=(tail call)"]: ?
[string "@SharedXML/SharedUIPanelTemplates.lua"]:1198: in function <SharedXML/SharedUIPanelTemplates.lua:1194>

self = BossTargetFrameContainer {
 0 = <userdata>
 UpdateMagnetismRegistration = <function> defined @FrameXML/EditModeSystemTemplates.lua:521
 GetSnapOffsets = <function> defined @FrameXML/EditModeSystemTemplates.lua:421
 systemInfo = <table> {
 IsFrameAnchoredToMe = <function> defined @FrameXML/EditModeSystemTemplates.lua:484
 breakSnappedFramesOnSave = true
 LayoutChildren = <function> defined @SharedXML/LayoutFrame.lua:192
 GetSelectionOffset = <function> defined @FrameXML/EditModeSystemTemplates.lua:373
 ResetToDefaultPosition = <function> defined @FrameXML/EditModeSystemTemplates.lua:158
 GetScaledSelectionSides = <function> defined @FrameXML/EditModeSystemTemplates.lua:365
 SelectSystem = <function> defined =[C]:-1
 GetFrameMagneticEligibility = <function> defined @FrameXML/EditModeSystemTemplates.lua:504
 UpdateSystemSettingUseLargerFrame = <function> defined @FrameXML/EditModeSystemTemplates.lua:986
 CalculateFrameSize = <function> defined @SharedXML/LayoutFrame.lua:148
 AddLayoutChildren = <function> defined @SharedXML/LayoutFrame.lua:48
 smallSize = false
 IsBelowFrame = <function> defined @FrameXML/EditModeSystemTemplates.lua:332
 spacing = 10
 respectChildScale = true
 HasActiveChanges = <function> defined @FrameXML/EditModeSystemTemplates.lua:254
 GetScaledCenter = <function> defined @FrameXML/EditModeSystemTemplates.lua:358
 SetCastBarPosition = <function> defined @FrameXML/TargetFrame.lua:1369
 DoesSettingDisplayValueEqual = <function> defined @FrameXML/EditModeSystemTemplates.lua:278
 Layout = <function> defined @SharedXML/LayoutFrame.lua:170
 settingDisplayInfoMap = <table> {
 GetSettingValueBool = <function> defined @FrameXML/EditModeSystemTemplates.lua:269
 alwaysUseTopRightAnchor = true
 IsLayoutFrame = <function> defined @SharedXML/LayoutFrame.lua:36
 DoesSettingValueEqual = <function> defined @FrameXML/EditModeSystemTemplates.lua:273
 MarkDirty = <function> defined @SharedXML/LayoutFrame.lua:90
 UpdateSelectionVerticalState = <function> defined @FrameXML/EditModeSystemTemplates.lua:1101
 EMEanchorPoint = "BOTTOMLEFT"
 GetChildPadding = <function> defined @SharedXML/LayoutFrame.lua:133
 EMESystemID = 36
 IsToTheLeftOfFrame = <function> defined @FrameXML/EditModeSystemTemplates.lua:314
 GetSettingsDialogAnchor = <function> defined @FrameXML/EditModeSystemTemplates.lua:298
 hasActiveChanges = false
 OnSystemLoad = <function> defined @FrameXML/EditModeSystemTemplates.lua:3
 ClearFrameSnap = <function> defined @FrameXML/EditModeSystemTemplates.lua:458
 GetCombinedCenterOffset = <function> defined @FrameXML/EditModeSystemTemplates.lua:408
 SetupSettingsDialogAnchor = <function> defined @FrameXML/EditModeSystemTemplates.lua:963
 UpdateSystemSettingSortPlayersBy = <function> defined @FrameXML/EditModeSystemTemplates.lua:1077
 dirty = false
 SetPointBase = <function> defined =[C]:-1
 UpdateSystem = <function> defined @FrameXML/EditModeSystemTemplates.lua:203
 UpdateSystemSettingRaidGroupDisplayType = <function> defined @FrameXML/EditModeSystemTemplates.lua:1070
 UpdateDirtySettings = <function> defined @FrameXML/EditModeSystemTemplates.lua:122
 isHighlighted = false
 BreakSnappedFrames = <function> defined @FrameXML/EditModeSystemTemplates.lua:441
 PrepareForSave = <function> defined @FrameXML/EditModeSystemTemplates.lua:35
 systemIndex = 6
 isInEditMode = false
 UpdateSystemSettingUseRaidStylePartyFrames = <function> defined @FrameXML/EditModeSystemTemplates.lua:996
 snappedFrames = <table> {
 UpdateSize = <function> defined @FrameXML/TargetFrame.lua:1303
 SetPointOverride = <function> defined @FrameXML/EditModeSystemTemplates.lua:71
 UpdateSystemSettingShowPartyFrameBackground = <function> defined @FrameXML/EditMo

That just worked for me.

  1. Went to another character
  2. Enabled all action bars
  3. Copied my custom profile
  4. Went back to my main character
  5. Selected the copied profile
  6. Made desired changes
  7. Changes now will save

Still there must be a bug… a couple days ago my profile completely disappeared. Now I couldn’t save changes without a work around…


A combination of the two methods worked for me. Delete the specified files from all toons and then turned on party and boss and raid frames in edit mode. Boom, can save and create templates without error. Thanks!

good god i was going through my addons and thinking it was an addon or a weakaura, then at one stage i said fine ill turn you all off…lua error.
the copy/delete worked, but it naturally errors right after.

Some good info in this thread, but MAN-- idk… This a really basic error that should have been caught before it was allowed to go live.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.