Low Level Leveling - Problematic

I’ve been noticing some issues with lowbie characters. Aside from Exile’s Reach being constantly broken due to hunters taming the boss mob, when trying to level in old world content, the game has been doing some very quirky things.

At level 10, you are given the opportunity to go to any of the past expansions (BC/Wrath are 10-30, Cata/MoP are 10-35, WoD is 10-40, Legion is 10-45, and BFA is 10-50). That’s fine in theory, but there are several occasions where high level content is phased incorrectly.

Take Legion, for example. Starting out on a newbie warlock, I went to collect the Artifact weapons, and the imps and bats around Karazhan are skull level mobs that instantly kill the character. The Artifact weapons were level 20 (and do not appear to scale up), where things like the Order Hall armors are showing in the 50ish item level.

I had tried previously leveling a NE druid and was immediately teleported at level 10 to a BFA scaled Darkshore without quests and instakill mobs. I’m still roaming around, but definitely needs a lot of polishing before releasing.

Also, heirlooms are back, and while they don’t have the XP bonus, you do get a nice set bonus for the number of pieces, and does diminish the amount of rested XP consumed, so decent tradeoff. Leveling in general is going fairly quickly, imo.

5 Likes

Yeah, getting 1-shot by an Imp is embarrassing. At least I know I’m not the only one. I did finally get Scythe of Elune, but it ended up being a corpse run to get inside the tower.

Wait, is that why there’s never any way to save the mage? I’ve logged in at random times repeatedly. Is it a beast?

Yep, it apparently summons a Roc beast, which hunters have been taming so the quest never registers as completed >.>

2 Likes

Yeah, there’s not even any mob spawned at the quest I’m on; nothing to attack, no way to progress the quest.

The way I see it, the Exile’s Reach situation has a few possible solutions, with varying levels of consideration for the players:

  • After x amount of time, reset the NPCs, allowing the event to be restarted (not a huge fan of this one, but it solves the problem)
  • After x amount of time, where there is no Roc present, spawn another Roc (if not done properly, could be abused by tanking the original Roc away from the area, and ending up with multiples)
  • Flag the Roc as untameable (not fun for Hunters who want the pet)
  • Taming the Roc completes the current event (might ruin the epic-ness of the fight, but just a suggestion)

Am I missing another possible solution?

(Edit: #2 might not be a big deal, since you don’t have taunts at that level, as long as the game realizes whether there is a Roc already spawned or not)

Right now, it’s just endlessly spawning Harpies.

I don’t think they have Chromie time really working yet or low level zones for that matter. I hope that is next build. I tried going to Howling Fjord (was the correct level) and no npcs no mobs no nothing… I really want to test this feature and fully relive old xpacs

Warlords of Draenor questing is also broken. The game demands you be level 35 to learn the blueprints for the Garrison…

did you turn on chromie time? by going to chromie in stormwind? the only bug i found so far is with Northrend the boats not showing up to take you there.

In my case, I have tried both with and without Chromie Time. Both ways I cannot use the required item.

Yes, it’s a large Roc. Nothing special to look at either, so I don’t see a reason for taming it other than “Starter Island Pet lulz”. Logging in at random times is literally your only hope to get it done though - that’s what I’ve been doing & finally did manage to get it done on my Horde lock. Still trying with the Worgen though - NOW the encounter is bugged at the first part; when you start it, you will have to kill a couple waves of 2 Harpies, then the NPCs come & you fight a couple more, then the “boss” arrives. Now, you just have 2 Harpies over and over and over and over… NO clue what might have happened to bug it like that.

Go to Borean Tundra, that area is working as intended. Just be careful heading into Crystalsong - the yellow mobs were 25 & the wolves may well have still been 70-80ish. They were ?? skulls to me. There still will not be anyone at all in Howling Fjord though. I suspect (from something in another thread) that it’s due to a Legion Artifact quest taking you there. If Legion scaling isn’t yet finished, that could be throwing off any areas in Azeroth one might travel through that are also required for Legion. That would also explain how I died in Deadwind Pass and FLEW back up to where my body was (on a gryph). I was headed to Swamp of Sorrows to go to Outland, saw a spider drop behind my character, ~thought~ said spider had a skull, then game froze & booted me out. When I finally got back in, I was dead & on a gryph. When I rezzed though, the spiders were level 12 & I had no problem getting through. So there may be phasing issues as well as scaling issues.

Incorrectly scaling mobs have been an issue since the legion pre patch invasions, where one mob in Westfall could summon other enemies, and the enemies that were summoned would always be max level. I reported that and other examples that have popped up through the years, but never once have I seen a scaling issue resolved… :crying_cat_face:

2 Likes

With scaling being this prevalent to the expansion, though, they will need to do something about insta-kill mobs in all of these improperly scaled zones, though.

The main ones are, where you are doing your artifact weapon quest in an old non-Legion zone, and there are normally-trivial mobs one-shotting you. I’m looking at you, Imps in Deadwind Pass. I just corpse-run to my destination and get it done, but the average player will most likely not tolerate this type of shenanigans.

4 Likes

I certainly hope they do take a look at this; however, I’m not holding out luck with it being fixed before the pre-patch, since problems with scaling mobs have been very low (or no) priority to Blizzard thus far over the past 4 years.

Ok, I found Chromie over by the Embassy, and did the quest to lead over to Legion content. I’ll see if it corrects any of the scaling issues I’ve been seeing.

There really should have been a bread crumb quest or indicator leading players there. There was nothing on the Quest board, or even in the Adventurer’s Journal pop ups. It just gives you the quests and go.

4 Likes

Call me blind. But where is Chromie on Horde side?

Supposed to be outside the Embassy. Check around, she was sitting atop an hourglass (near a tree on Alliance side). I’ll have to check Horde when I get a chance later.

When you are approaching the embassy, but before going in, take a 90 degree turn, and she is mixed in with some NPCs, sitting on her hourglass.

She is just inside the gates to the area, on your left, sitting atop an hourglass behind the fire. There are two goblins flanking her & you’re not seeing her because she’s both tiny AND her name is green rather than yellow. At least that’s why I didn’t see her at first :smiley: