Live chat always unavailable?

Ive been having an issue changing my phone number, so i contacted support. However they got back to me saying I need to contact the web chat for them to assist me correctly.

Ive been trying for a whole 2 days now and the live chat always says its unavailable even in the right hours…

1 Like

You’ll want to inquire in #support:customer-support since this is not a technical support issue.

1 Like

Live chat is sporadically available. You can request a phone callback in your ticket and they should reach out to you that way. Blizzard poster linked below from the CSF.


Not having the live chat available is a real pain in the patukis. It was a lot more fun being able to converse with friends during the game. I would expect that the powers that be would fix this issue. They have lots of talent around the shop.

When they refer to “Live Chat” they mean billing and technical support, not being able to communicate in game.

Not being able to converse with friends is not the same in this case.

Did you have a billing or technical support question?


Sounds like someone got silenced and is trying to apeal via live chat.


Interesting observation. Appeals are not taken by live chat.


Oh i could be wrong but thats what it sounds like.

1 Like

Same exact thing for me. I was told I had to contact live chat for it, and it’s never available every day when I check during the times it says. It’s been almost a week. I tried different browsers and different devices lol.

So you are unable to see the Live Chat option OR is it always just greyed out for you?

What does it show for this link?


This is what it shows for me. When I first landed on the page it showed as unavailable, but quickly changed to open after a few seconds.

At that link it shows the button for live chat, but it’s crossed/grayed out and says
" Live Chat


Open: 5:00 AM - 3:00 PM PDT"

It shows the same whether I’m logged out, logged in, different browsers, and I even tried it on my phone.

Once the live chat time window ends, the button goes away entirely.

It’s open at the moment. If not available, you won’t see that icon at all.

Some seem to have that issue. Could be a few things. Settings, ad blockers - even security software or other software running that uses overlays.

But yes, it’s open. I would leave the page up for just a bit, see if it lights up. If the queue is full, it will be greyed out, but that is usually temporary.


Try incognito mode, or private, depending on which browser you use, it’s showing as open to me though. Not sure why it’s not for you.


I’ve tried it on Firefox, Chrome, and even Edge(which I haven’t added any addons to/changed any settings), and they all show the same thing. I even just tried on my phone again(which I haven’t enabled any addons/changed settings either). I tried incognito as well as regular browsing.

I even tried it on a fresh Chrome OS install with no customization. Nothing. It just says unavailable.

I even tried disabling IPV6 if that was a problem, and that didn’t help either.

I used to use live chat in the past just fine maybe a couple years ago, and I haven’t changed anything since.

I’ll try leaving it open for an hour and see if that does anything.

I even tried to force a live chat by using the direct /chat link at the end of the URL to submit a ticket via chat, and it just made a regular ticket.

Make sure you don’t have any overlays running in the background. Some mice, video cards, and communications software uses overlays.

I have no software like that running in the background, and I see the same thing on my phone/clean Chrome OS install laptop.

I can go to the url that assumes I have the chat button selected (ex. ) , but even there it says it’s unavailable despite it being selected. I’ve tried a couple times to submit it through the direct link, and it just makes a regular ticket, so I end up cancelling it.

Edit: I ended up getting it to randomly show after a lot of attempts.

May I ask what exactly is the issue you’re seeking help with? Perhaps we can offer some assistance if it’s not something that requires your account/billing information. Or perhaps we can offer some different way to go about resolving your issue?


Thanks for the concern. I was able to finally talk to someone(out of all of the browser combinations I tried, Chrome without incognito was the only one to give me a chance at seeing it active, everything else didn’t lol. It took a lot of chances, but it eventually happened.

They unfortunately weren’t able to help me though. Was trying to add a number that wasn’t taken by the website, since Overwatch 2(only posted here because this is where I saw most of the live chat issue threads) says you need a phone number to play the game. They weren’t allowed to add it for me manually, but I also wanted to talk to someone to confirm something mentioned in my previous ticket. The ticket mentioned it was required to only “create” an OW2 account. I wanted clarification if that meant that those like me who paid $40 for Overwatch 1(which is getting deleted for OW2 which is free to play), would be grandfathered in, since we already ‘created’ an account.

They didn’t really have much information on the subject, and I hope they decide to grandfather in existing accounts prior to the OW2 launch, because it’s a bit messed up to lock me out of the game I paid $40 for.

Anyway, thanks for the help all. I’ll have to see if I can borrow a friend or family’s number in the future, if they decide to not grandfather people in. I can’t really afford a different phone/service right now.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.