Lag/Jittering with every quest hand-in/Level up

Sure. I’ll just read 619 comments just to know if I can post the fix I found after searching a bit.
I have something called a life.

Gonna be straight - if this bug wasn’t possibly destroying people’s hardware, I’d say sure to this kind of mentality. I usually do on other things. But when peoples’ hardware is at risk? When people’s CPU’s which govern so much is at risk? That’s worth the outrage. This comment feels uneducated to me.

Edit: I’ll also be straight and say I’m not saying people should riot or lose their minds. I’m sure Blizzard is doing their best. But this is a problem, as other people have pointed out, in the long run. Blizzard ain’t gonna replace an HDD that’s suffering because of these things.

Also I just restarted again and, as others have reported, am still experiencing this bug.

3 Likes

Same here…tried all solution but still the same…i thought I’m the only one…after read all the comments, well, this sheet is real after the patch…HOpefully, Blizz will come out with solution soon…

ave you tried what was posted above? Changing permissions or setting the Logs file to read only?

As of today, I am no longer experiencing lag/stutter when I loot mobs but its still present on quest turn-ins (much less than previous.) I’ll keep using the read-only and launch from .exe fix until the next update.

Hey all,

Just a quick update on this, it looks like our dev team is working on a fix for this issue as we speak. We do not have an ETA for when the fix will be live but we hope to get it to you all as soon as possible.

Thank you for the continued reports and for your patience in all this.

23 Likes

Thanks for the update and we appreciate the dev team making the fix a high priority.

I get what you’re saying. I really do. But if there’s so much concern over ruining hardware (when a temporary fix DOES work, so that kind of confuses me…), then don’t play for a few days.

Risk it and burn up your computer (unlikely, but sure I guess it could happen?)

vs.

Not playing and letting it ride.

Trust me. I get what people are saying. I just think that the knee-jerk reactions are an old song. Is Blizzard slow to fix it? Sure, I guess? Do they have a reason? Maybe, I dunno? But sometimes software just doesn’t work like we want it to, no matter who is to blame.

Personally, I like to think they’re trying their best. I’ve been playing this goofy game for 14 years now and there have been TONS of situations where I have had to step away from it for a few days because of a hardware or software issue, etc.

I dunno, I guess I’m just trying to see things from a different perspective and not add to the hype.

ETA: I seriously roll my eyes when people take this kind of situation and decide to turn it into the whole “OMG BLIZZ BFA SUX, SEE???” argument. It just seems silly. This bug has nothing to do with the quality of BFA.

4 Likes

Nice. I hope it’s fixed before the weekend. Thanks for the update.

Oh hey, nice to know someone is still breathing over there. Thanks for the update :smiling_face_with_three_hearts:

You. You’re the one who said what we’ve been wanting to hear this WHOLE TIME.

Whether or not there even is a fix. You said it.

I disagree. The same people that made BFA put out this patch with this bug. This entire expac has been a technical nightmare…

2 Likes

Like I said - I don’t condone people losing their minds or anything of the sort. But this bug has been around for nine days. The “workaround” you mention is not sanctioned by Blizzard whatsoever, and is advised against by them, with them so much as tagging on “do so at your own risk”. No matter what, if players use the workaround, or if people wait, there’s some kind of risk / loss going on.

It’s a pretty crappy situation to be in. While I do not condone people flipping out unnecessarily, and I never will, I am empathetic to their frustration, which is what this is. People are frustrated. It’s not people being dumb over something like Pathfinder or Allied Races, which I always sit here and speak out against. It’s concern for their expensive equipment. Can’t really fault them. Everybody’s different. Rolling your eyes and antagonizing other people doesn’t do anything either. And those people will take it as antagonizing. It’ll just add to their frustration and make it worse.

Edit: It’s fine if you disagree with those people. But the smart thing we should all be doing is trying to dissolve the situation while ensuring we continue to give Blizzard the information needed. Not be like: “I’m rolling my eyes at you, you’re dumb”. That’s how some people will take that.

On the plus side, I’ve had some much-needed alone time with other games, so I won’t have that nagging “You haven’t beaten Hollow Knight! Why did you buy it?!” haunting me while I play WoW all day.

Don’t do this again, please, but at least SOME good came out of it for me.

(But jokes aside, this was terrible, the stress wasn’t worth the wait.)

1 Like

So, there’s maintenance tomorrow for one hour. Is that when the fix will be deployed I wonder…

1 Like

Google “try changing hpet settings to improve your pcs performance”

This definitely impacted the stutter. Disabling hpet in both device manager and in bios (advanced --> ACPI Config) created different results.

It didn’t fix the stutter. It’s pretty clear it impacts the entirety of the PC. You can see the file explorer screen refresh? at the same time as a stutter; you’ll see the toolbars and scrollbars in that explorer window react. All windows and cursors, etc will stutter.

I have ElvUI. While typing this, my character went afk. My stutter is now about 3-4 per rotation of the afk screen in their addon. My character is just sitting, in Uldum.

I am running a radeon RX590 on an amd ryzen 5 3600. 16GB ram. My SSD is M.2 Intel 660P.

My girl is running a radeon RX580 on an intel i5-9600k, also with two Intel 660P’s. She also has stutter although it’s not quite as dramatic as mine. 32GB RAM.

I don’t know if this will help Blizz fix the issue… I tried the hotfix/tooltip permission ‘fix’ and although it did improve, it still stuttered. I was intelligent enough to realize that the battle net app replaces those files and can be circumvented simply by running wow directly from it’s *.exe

But whatever the issue, it has to be in this neighborhood of issues.

I sure do hope so, crossing all my fingers, hands and feet.

2 Likes

Me too. We’ll do it together!

1 Like

Having the same issues on my end too, this started happening after the recent patch, I have reset my UI too, nothing is working.

Hoping tomorrow’s maintenance solves this issue!

1 Like