Join as a group failed for specific battlegrounds and arena skirmish

Unable to queue for arena skirmish and specific battlegrounds for the following battlegrounds:

The Battle for Gilneas, Twin Peaks, Silvershard Mines, Temple of Kotmogu, Seething Shore, Deepwind Gorge

The error message is as following: “Join as a group failed”

Able to successfully queue for random battlegrounds, warsong gulch and arathi basin

please see

This “join as a group failed” error affects Korrak’s revenge queue as well: So... Korrak Revenge bug which is being investigated as per the blue response:
Hopefully the upcoming fix for korrak’s revenge will include the fix for specific battlegrounds too, as I really want to queue for something else other than warsong gulch and arathi basin.

Bump: Korrak’s revenge is now fixed, but specific battleground queues are not.

Only low level characters are affected, who cannot queue for specific battlegrounds.

On my level 25 character, I can successfully queue for arena skirmishes and specific battlegrounds (The Battle for Gilneas, Twin Peaks, Silvershard Mines, Temple of Kotmogu, Seething Shore, Deepwind Gorge).

However on my level 11 character, I cannot do the same. The “Join as a group failed” error message is still displayed, even though I am not in a group. Can we get that fixed please?

2 months later and this is still not fixed!
I still cannot select a specific battleground other than AB and WSG and queue for it on my level 10 character. Same message is displayed “Join as a group failed”.
Why am I seeing those specific battlegrounds in the list (The Battle for Gilneas, Twin Peaks, Silvershard Mines, Temple of Kotmogu, Seething Shore, Deepwind Gorge) if I cannot queue for them?

If you wish to queue for those, you will need to level to the appropriate minimum level for those bg’s. According to Wowhead, Battle for Gilneas requires minimum level 20. Twin Peaks minimum 30. Silvershard Mines minimum 50. Temple of Kotmogu minimum 50. Seething Shore minimum 40. and Deepwind Gorge minimum 50.

Yea I’d really love my battleground list to reflect that please. Its misleading when I’m all getting hyped up at being able to queue for all those listed BGs at level 10 only to be disheartened by the fact that you cannot. And why can’t we anyway?

That is not true, I can queue for Silvershard Mines, Temple of Kotmogu and Deepwind Gorge at level 48. But you should definitely be able to queue for them way before then. I understand if Blizzard is keen to keep f2p trials out of those BGs, then why not limit the entry level requirement of those BGs to a level 25? Trial accounts are capped at level 20, so they never will be able to queue for those battlegrounds unless they buy the game. But why limit subscribers to a certain level range to be able to play a legacy content?

Indeed, out of those 6 BGs you’ve listed, I can only queue for Battle for Gilneas at level 25. Its so stupid. At level 20 you can get fastest ground mount possible, so if there was some reason behind not introducing those battlegrounds before that level due to whatever balance issues, it is no longer the case at level 20 as everyone rides super fast by then. I also could swear I was able to queue for some of those BGs before SL, Twin Peaks definitely, but maybe others too. And now I can’t due to this min level req bs…

I can’t believe it has been almost a year and a half, and this is still not fixed

Why are there battlegrounds displayed in the Group Finder > Players Vs Player > Quick Match > Specific Battlegrounds drop down list that I cannot queue for?

Why is there a misleading message that says “Join as a group failed” even when I’m not in any group at all when I try to queue for those battlegrounds?

Why is the error message not truthful and clear, i.e. when I try to join Silvershard Mines, the error message doesn’t say “This battleground becomes available at level 50” or whatever the required level now is?

Why the high level battlegrounds in the Specific Battlegrounds list are even clickable by the low level character instead of being greyed out with the tooltip on hover: “This feature becomes available at level xx” like the Premade Groups option is for example when a character below level 50 tries to click it?

Why does arena skirmish display no message at all when I try to queue for it? Not even the incorrect “join as a group failed” one. It just fails to queue…

1 Like