Item missing, ticket auto-closed

So, I dragged and dropped my artifact fishing pole (Underlight Angler) onto my character’s weapon slot and it disappeared from my inventory. The appearance was on my character for a bit, but then it switched back to my staff. (it was like it transmoged my fishing pole onto my weapon)

I looked in item recovery, but the item isn’t there.

I opened a ticket and it was auto resolved with “some resources” because of “the ticket queues being extremely busy.”

Those resources being some links to the Dragonflight common issues, support articles, game info and guides, and the forums.

I don’t know HOW this saves me time.

So in the email I received it also said “If you continue to experience issues, you can reopen this ticket. If you have a new or separate issue, please submit a new ticket.”

So how do I reopen the ticket? Just submit a new one? I feel like it will just be auto-closed again.

Any helpful ideas?

Have you tried to do a full UI reset? That is often times the first thing any issue is asked to do. It’s amazing what a borked UI can hide away or move or what have you.


I’ll start with the issue at hand, maybe this will help? Assuming the missing item in question is the artifact itself.


I’m currently going through the same thing but with a Mekgineer’s Chopper mount. Was putting it up on the AH. Just as I clicked the button to list it the server crashed and when I got back into game the mount was gone.

Opened a ticket and got the same response you did in the first 30 minutes, the email told me to do the usual stuff of logging out/in, item restoration etc. I had already tried all of those with no success.

Put in a second ticket because there was no way for me to reopen the first one. A few days later I got the exact same auto generated response but this time they were kind enough to also include a customer satisfaction survey :face_with_raised_eyebrow: and they closed the ticket, again.

Put in a third ticket. That one took 2 weeks to get answered and all I was told was that I have a Mekgineer’s Chopper in mount collection so I must have used it so that is where it went. Never even addressed anything that I put in the ticket as to what happened with the server crash. They closed the ticket but this time I was able to reopen it.

So now I’m waiting, again, after reiterating all the steps I’ve taken and what happened when the the mount disappeared.

I’m so frustrated right now.

1 Like

Thank you, that was it!
It would have been helpful if there was some sort of confirmation box to let you know something unusual was about to happen…

I’ve been there…sorry you’re still having the issue.
Luckily, my issue has been resolved.

1 Like

No, what the OP has posted is EXACTLY what just happened to me. I know because I saw my graphite pole and attempted to move it manually after getting the message “that item does not fit in that slot” msg when I tried to use my outfit macro.

So I guess if you don’t have Dragonflight fishing training and so either this is a hotfix or you don’t get to have fishing poles in Waking Shore, so that just means no fishing buffs, but you can still have ones for the reading impaired. wink wink. :rabbit2: