Illusion: Wraithchill


(Ekon) #21

I can confirm there is no red outline looking at the appearance on a level 20.

To clarify-- what this thread is about. The illusion is available to level 20 and above, no input on any characters below level 20.


(Nømed) #22

I have the mount, the quest from the mount to get my xmog set. The new hearthstone toy. The weapon xmog Wraithchill.


#23

I got the mount, pet, level boost and the hearthstone but i cant find the illusion…


(Tmali) #24

Add me to the list. Got the mount, pet and boost but no Illusion. GM ticket opened…


(Ekon) #25

Yup, that’s all you can do for now. The hotfix they pushed didn’t have a way to retroactively apply to people who opened their packages, so they’re collecting tickets to send out what’s missing en masse.

Just be sure to specify the character that’s missing it and what is missing, and they’ll send them out eventually!


#26

The Illusion is part of the Shadowlands Epic Edition, not the 15th Anniversary. Those items didn’t disappear.

The Wraithchill Illusion should be located in your appearance tab, under Weapon Enchantments.

Imgur

Did you check that area, Tmali? Have you tried resetting your User Interface?


Preorder Bundle Bungle
(Ekon) #27

Ugh, yup. I knew that, too… there’s been a lot of overshadowing (can’t decide if pun intended) anniversary stuff, it would seem. Apologies!

Coffee might do me some good, too.


(Tmali) #28

As noted, I purchased Epic Edition on day one. Still don’t have the Illusion
EDIT: resetting the cache folder fixed it. Thank you Vrakthris


#29

Actually, I can’t believe I didn’t do this first, but I am looking at your order and the Shadowlands license you purchased and it is Heroic, not Epic. Heroic doesn’t include the Illusion.


#30

but does it work on balance of power ashbringer?


(Tmali) #31

Not sure who you’re speaking to but I definitely purchased Epic Edition and have the receipt to prove it. If you’re seeing Heroic something is very wrong


(Rufflebottom) #32

Most likely Akushirokuma, who posted just before you.


#33

Neither. Looks like I had the wrong account (trying to do too many things at once), sorry for the confusion. Glad to hear the reset helped, Tmali.


(Akyda) #34

Protpalli, do not fear. I don’t have it either. all I got was the pet and mount, but have nothing else. no hearthstone, no wraithchill, none of the goodies others seem to have. Makes me feel better that I am not alone… but… I paid for it, they took the money so … lol where’s our stuff right? lol


(Perl) #35

Did you make sure that you purchased the Epic version Akyda? And if so, was it very recently purchased? It can take a little bit for everything to come through. Also, logging completely out of the game and launcher can help.


(Akyda) #36

Hey Perl thank you :wink: I did purchase the epic edition… it was on november 2nd I have the Blizz email receipt thing and double checked just to make sure I didn’t flub that up … :confused: I will try logging out completely as I haven’t done that yet.


(Perl) #37

And just to be sure, you’re looking in the Toy Collection for the hearhstone and in the weapon enhancement options when doing a transmog?


(Kyzera) #38

Did you make sure that all the filter sources are checked in your Toy Collection to check for the hearthstone toy?

Also, did you make sure all filter sources are checked in your Appearance Library as well? You will need to have a main armor piece selected in order for the Filter option to show up.


(Akyda) #39

Kyzera, okay well… you have me stumped here lol… that’s something I’ll have to look at as I’m not sure? I’ll get back to you on that…

lol well I feel silly but… if I didn’t ask, I wouldn’t have known… there were there indeed! thanks alot :slight_smile:


(Kyzera) #40

You’re welcome. Glad you were able to find them.