How to turn on Ray Tracing if your Settings is broken

So if you have an RTX card and have updated the new drivers you might notice that some people can flip Ray Tracing on while others cannot, this appears to be a bug with the actual menu, not the system. If you are not comfortable adjusting settings in the .ini please disregard as this is for people who want to turn it on but cant, can and for Blizzard to see that there is currently a workaround

If you go into _ptr WTF access your Config.ini and at the very bottom you will see 2 lines
SET shadowRt “0”
SET RAIDshadowRt “0”
Switch them to 1 (Fair) ,2 (Good) or 3 (High) and you will have Ray Tracing on if you have the driver and hardware

4 Likes

Will have to try it when the PTR is back up working again.

I have a RTX 2060 and the option is there, but when I flip it on or off, I’m trying to see any difference in the shadows and I can’t. Also, any idea if other Shadow Options should be set differently like HBAO and even normal Shadow Settings?

WoW’s ray tracing implementation uses DXR 1.1, not DXR 1.0.

To be able to use DXR 1.1, you have to be on the most recent version of Windows 10 (the 20H1 release, 2004) and have DXR 1.1 capable graphics drivers.

11 Likes

Check on all accounts as far as specs go, and I finally found a spot were I could test this out and was able to spot the subtle differences. That took place, before I got disconnected. Honestly, that is my main annoyance. I can never seem to be able to stay on the PTR long enough to test anything before DCs or not being able to get back on somehow.

1 Like

That might explain it as I’m on 1909 still.

Edit: It was good to try to update now. Turns out my Windows Update was stuck and last package was corrupted. No wonder I didn’t have the latest.

Nods, 2004 update instituted the DX 12 Ultimate update as well as NVIDIA drivers a while back that updated to this version of DX 12. Of course you had the update to Drivers yesterday to work better with the PTR. Thank god also because with the limited testing I’ve been able to do, performance has gotten much better compared to before the driver update.

1 Like

Cool, that means my fix probably wasn’t doing squat, thanks for the heads up.

Probably, it’s definitely one of those matters. Especially since Windows I know wasn’t pushing that update out to everyone right away while they figured out hardware issues/compatibility matters. I know I had something saying that at first for the update before I was able to download it eventually.

Thanks for tryin to help though. at the very least it gave me the drive to find this post.

Yea apparently my Windows Update didn’t go through with that update as well.

If your progress is stuck at 0%:

  • Press Windows+R . This will prompt a run dialogue box. In here, type services.msc
  • Scroll down and look for Windows Update Service . Right click on it and stop it
  • Navigate to C:\Windows\SoftwareDistribution and delete all of its contents
  • Restart the Windows Update Service

This worked for me. If the service won’t stop, try restarting first.

After cleaning the update, I was able to update to 2004 version.

1 Like

I can confirm. After updating my Windows to version 2004 update, I was able to now select the Ray Tracing options.

Working like a charm here after today’s update. The soft shadowing and sharper shadows up close look quite nice, but it’s unsurprisingly at a massive performance penalty. Certainly an exciting glimpse into the future between GPUs with faster RT capabilities and more updates down the road.

2 Likes

Now just got to get the servers stable and have character lists to load.

I lose about 20 FPS when I turn on ray-traced shadows, but it doesn’t really look any better. There is also no FPS difference between low, fair and high.

1 Like

Has anyone else been getting background errors showing:

This application has encountered a critical error:
ERROR #123 (0x8510007b) This memory block has been corrupted by an out-of-bounds memory write.

Program: \wow install location_ptr_\WowT.exe
ProcessID: 8864
ThreadID: 8508
File:
\wow install location again\BuildServer\WoW\2\work\shared-checkout\branches\wow-patch-9_0_1-branch\Storm\Source\SMemMalloc.cpp
Line: 1684

Memory corrupted –
same file path as above up to \wow-patch-9_0_1-branch\Engine\Gx\src\GxApi.cpp 419

Press OK to terminate the application.

The game doesn’t actually crash; it just flashes to desktop, generates that error, and then the game is still playable afterward but RTX seems to be disabled after the program loses focus and the error is generated. Seems to be tied to using RTX since it doesn’t happen otherwise, amount of time varies before it happens but it’s happening reliably every time I run the game. Running a 2080 Super on 452.06 drivers, RT shadows set to High in game. Had it happen on the new starting island area with new characters, and in Boralus with copied ones, so it doesn’t seem location specific.

/edit: Edit to say that this does not happen on the beta client as I was playing tonight, I only experience it on the PTR. For people looking at the performance hit, performance also seems to be significantly better on beta, but I didn’t test that in a lot of different areas.

1 Like

Any word on mac support? Coming at some point, or perhaps not at all if Metal isn’t compatible?

I was actually quite disappointed with the performance penalty. It was hard to find all but a few places that DXR seemed to have an effect.

  • Reflections: Not yet supported. Still improperly reflecting through objects that would block light (Used the bridge under boralus looking towards the catwalk, the catwalk should block reflections of the arch it does not), this can be solved without DXR.
  • Shadows: Elwynn forest destroys performance even on a 2080 with ‘fair’ settings. This is likely due to the global illumination, that should optimized.

Overall… it’s there… but I didn’t see anything spectacular to write home about yet. I look forward to rev 2.0

1 Like

To summarize, testing ray tracing in the Shadowlands Beta requires that you:

  • Use DirectX 12,
  • have a GPU that supports DirectX Raytracing Tier 1.1, with the latest drivers installed and used, and
  • have the May 2020 update for Windows 10, version 2004.
1 Like