How to get into the PTR

If you’re still not testing the PTR (Public Test Realm) with us, and you want to, we’ve made it easy to get started. Just follow these steps:

CREATE A PTR ACCOUNT:

  • Log in to Blizzard Account Management.
  • Select Games and Subscriptions.
  • In the Starter Editions & Public Test Regions section, select Create PTR Account.
  • Click the Create Account button.

JOIN THE PTR:

  • Open the Blizzard Battle.net App and select World of Warcraft from your Games list.
  • In the selector above the Play button, change your Region / Account to PTR: World of Warcraft.
  • Click Install to install the PTR client. This becomes a Play button when ready.
  • Click Play to log in to the PTR, and select any of the available Test Servers.
  • Create a new test character, or copy over a character from your live account using the Copy Character button.
  • Enter the game and test the new content!

I have been trying to get into the 8.3 ptr and I already have an ptr account and client downloaded. Is it still live on the test realms

It’s down right now.

Any ETA on when the PTR should be back up and running?

1 Like

the news panel yesterday said it would be back up at 8 am Pacific time here in the US but here it is past and all PTR realms are still offline

8.3.0 32414 PTR is up.

1 Like

There’s a crash issue I’m seeing on the PTR - starting once I copied a character from Live to PTR. (This happened prior to today’s new build as well.)

This application has encountered a critical error:

ERROR #134 (0x85100086) Fatal condition!

Program:	C:\Program Files\WoW-PTR\World of Warcraft\_ptr_\WowT.exe
ProcessID:	13908
ThreadID:	12200
File:	d:\buildserver\wow\2\work\shared-checkout\branches\wow-patch-8_3_0-branch\wow\common\componentcore\charactercomponent.cpp
Line:	7443

AddItem with invalid display ID(181248)

<Exception.IssueType> Exception
<ExceptionType> Crash
<Exception.Summary:>
ERROR #134 (0x85100086) Fatal condition!
 AddItem with invalid display ID(181248) at d:\buildserver\wow\2\work\shared-checkout\branches\wow-patch-8_3_0-branch\wow\common\componentcore\charactercomponent.cpp(7443)
<:Exception.Summary>

What’s interesting here is that it refers to a file path which obviously doesn’t exist on my system - it likely does exist on the build server Blizzard is using. I’ve tried various things from deleting the cache, the PTR install, and graphics settings. None of it works. The moment I login and it hits the server (which I can’t change due to the crash), this error pops up, the game crashes, kaput.

1 Like

I logged into the PTR and its not letting me make Panda Death Knights says i need shadowlands but i already bought it

Who do we contact if there is a bug?

I’m trying to do the “Soulbound” quest but it keeps bugging out. With out this quest it appears i can no longer progress in Nazmir.