Garrison Resources Cache not showing with boosted character

Hi, there!

I can’t complete the quest “Finding a Foothold”. The NPC Prophet Velen phase out when he enter my garrison so I can’t turn the quest.

My character was booster to level 90 and then to 110. I already have a level 3 garrison. But my Garrison Resources Cache doesn’t show up and I can’t get resources to properly use my Garrison, so I’m losing WoD expansion major feature.

There is also a blue post related to this but with level 100 boost character: Garrison Cache Help

Thanks in advance!

Did you submit a ticket using the Stuck on Quest option that I suggested in that post, Felbud? A Game Master should be able to help get you back on track.

2 Likes

I did open a ticket (ID# #73721774), but they told me that my problem is a different bug from the one reported in the post and they couldn’t solve it. They also encouraged me to submit a bug report in game, what I also did. Anyway, the problem persisted and they couldn’t help much.

Interesting, I’m not sure it is. It might not be specifically from the level 100 boost, but from what I can see you have a Garrison but you don’t have the quests necessary to have established in the first place. Which is what I believe is messing up the phasing and your ability to access the cache.

I can probably put you back on track but in order to do so we have to reset the Garrison to set you at the Establishing your Garrison quest. That’s the easiest way to make sure that no quest/flagging is missed to mess things up later down the line.

If you are good with that, just let me know. I’m here until 7 PM PDT tonight.

2 Likes

Hi Vrakthris,

Thanks again for your answer.

Does this mean you will have to reset my Garrison to level 1 and reset all the upgrades I already have?

If this is the only way to fix this bug and have the Cache back I’m in. Anyway, I can upgrade much further without the cache. Is there anything that can be done to return the upgrades I already have once its fixed?

Not without risking messing something up.

I can try resolving the cache issue without resetting, but I’m not 100% that we won’t be in a similar situation. If you want I can try that and if it is still messed up you can just let me know.

2 Likes

Please, do it. I will report here how it went once it’s done. Thanks!

You’ll need to jump off the character. :slight_smile:

1 Like

Okay, done!

Alright, you can log back in and give it a try. :slight_smile:

2 Likes

Great work! The cache is where it should be now.

Not sure how it affected the questline but I will take a look and give further feedback here.

Thank you, Vrakthris!

EDIT:

The Garrison resources Chace bug is solved, but I still stuck in some other quests from Shadowmoon Valley and Garrison.

About the “Findint a Foothold” questline, I can’t complete the criteria “Gather Shelly’s Report” from the quest “Keeping it Together”(https://www.wowhead.com/quest=35176/keeping-it-together). Probably because I’m missing the NPC “Shelly Hamby” from the questline that starts with “Gloomshade Grove” (https://www.wowhead.com/quest=33271/game-of-thorns).

I think most of my Shadowmoon quest campaign will be messed up because my Garrison is already level 3. They should made that boost with level 3 Garrison to automatic complete all the questlines involved, probably all from Shadowmoon Valley. So it would work as intended. Is it possible somehow?

3 Likes

The original boost towards the end of Warlords of Draenor did complete the required quests as part of the process. Unfortunately, when the boosts changed with the next expansion it caused an issue with the process. Based on when your boost was applied my guess is that you were part of that.

I don’t believe it is possible to manually update the garrison, without risking some issues going forward. My guess is there are fundamental issues with doing so, which is why the “fix” is to give you kind of a clean slate so that all the quests and flagging happens normally.

I can restart the garrison, just let me know.

3 Likes

Please, you can restart the garrison. It will be needed to complete the other campaign questlines as I see.

(Even the Dark Portal quests are stuck because I’m missing Prophet Velen again with the quest “Step Three: Prophet!”).

1 Like

I believe that’s a breadcrumb quest, so that shouldn’t be available now.

You should be set. I made sure that the quests were completing normally so you should be able to pick it up from there. Sorry for the frustration, Felbud.

3 Likes

It’s all good. Seems like I can progress though the questlines normally by now, even if its from the start.

Although it is really frustrating to miss my progression due to a bug, at least I had a great Customer Support and thank you very much for that!

5 Likes

Glad I could help, Felbud.

I wanted to mention that you might not be able to complete any of the shipyard stuff until your Garrison gets back up to level 3.

5 Likes

Hi Vrakthris,

I did build the Garrison back to level 3 but I think I might got a bug in one of shipyard quests. I can’t complete the quest “A True Naval Commander” even if both objetives of the quest seems completed (1/1). I did the mission “Naval Blockade Mission: South Sea” but it failed after completion. The quest objetive is marked as (1/1), but the text line didn’t changed to gray color. Also, the South Sea Blockade quest doesn’t show up anymore. I already dropped and picked the quest again, but it didn’t affect anything.

Thanks!

Weird, looking at the mission history I can see that you started the mission but I don’t have anything showing it failed, was completed, etc…

Mind switching to another character so I can take a peek?

2 Likes

Sorry, I didn’t see your reply earlier but I was offline for couple hours by now. Not sure if you could take a look. Let me know if I can do anything.

EDIT:

So you probably already fixed it :slight_smile:. I just checked the mission again and it’s completed. Now I can get the next ones.

Thank you again for all the help, Vrakthris!

3 Likes

Sure thing, Felbud. Hopefully, that is the last of it and things will progress normally.

2 Likes