Free Character Moves Now Available in This Region

I did that and now I got into the character select screen and there isn’t a transfer button here for me.

When I try to transfer from Whitemane, there is only Sulfuras option not the Arcanite Reaper. Whats wrong with it?

How many transfers per account are we awarded?

You get one free character transfer.

This is False


"For approximately one day, the new realms will be restricted to only those players using a free character move. " A free character move. One.

People have transferred all their characters from one realm to another. Blizzard didn’t say how many. Your quote doesn’t implicitly or explicitly say about the limit


Why is the button not appearing on the character select. how am i the only one having a problem!!!

My guild is trying to switch off of thalnos to get away from the language barrier that has developed there. One my my members, who is my brother cannot get the transfer to pop up once logged in. i have done the transfer on my 3 characters and my other guildmates have done it as well. Is anyone encountering this same issue?

1 Like

Looks like it’s buggy at the moment

i am :frowning:

You can do your entire character lineup. There is no restriction.

1 Like

Same, I dont have the option either…

It’s on the “Realm is Full screen” after the realm select page when you get the position in queue count. Big red rectangular button labeled “Character Migration.”

Those that are having trouble, have you gone through this walkthrough?

Found it, click SHOP from char screen

yes, I have tried all that I think i am bugged out i dont even have the shop button on my character select screen. I have tried restarting my pc, the game, loading in logging out… Nothing .

Weird. You have a character on one of the listed realms, right? Blaumeux doesn’t have transfers.

yes i do, that was just the first toon that i made i have a 25 hunter on Fairbanks that i am trying to transfer over. But i restarted my game and cleared all my cache and cookies and then it put me back into the que and i am stuck in the perceptual loading screen for the shop now.

Ahhh. If you see the shop and it’s just not loading, that’s probably something else entirely. I know there were some people in modern WoW having trouble getting to the shop because of some antivirus and security programs blocking it or something. Not sure if this could be the same thing.

Did you do these steps? If you have to put in a ticket, that’s probably one of the first things they’ll have you try haha.

1 Like