Feedback: Alterac Valley Focused Testing


(Kaivax) #1

Once you’ve played through Alterac Valley in the Classic Beta, please post your feedback here.

Please feel free to report bugs in this thread.

===================
Known Issues

  • The Orgrimmar Priest trainer has gone missing. (FIXED)
  • Horde Warlocks and Alliance Hunters don’t have mounts. (FIXED - players may need to make new characters)

===================
Not A Bug

  • If you try to queue for AV as a group, you should get the “Incorrect party size for this battlefield” error.

===================

Thank you!


Warlock mounts what?
#3

Many people have the Beta & Stress Test option available in the drop down menu but can’t click play in the launcher. How do we know if we’ve been invited to AV testing or not?


(Fellína) #4

Priest do not have access to Race specific spells.
For example, No Devouring plague on UD

Edit:
Thanks for the update and dropping the priest ttrainers in ord them in Org

Edit 2
Using the scroll bar on the battlefield window creates a LUA error listed below

Message: Interface\SharedXML\SecureUIPanelTemplates.lua:237: attempt to index local ‘frame’ (a number value)
Time: Fri Jun 14 18:45:26 2019
Count: 103
Stack: Interface\SharedXML\SecureUIPanelTemplates.lua:237: attempt to index local ‘frame’ (a number value)
Interface\SharedXML\SecureUIPanelTemplates.lua:237: in function FauxScrollFrame_GetChildFrames' Interface\SharedXML\SecureUIPanelTemplates.lua:315: in functionFauxScrollFrame_OnVerticalScroll’
[string “:OnVerticalScroll"]:1: in function <[string ":OnVerticalScroll”]:1>
[C]: in function `SetVerticalScroll’
Interface\SharedXML\SecureUIPanelTemplates.lua:56: in function <Interface\SharedXML\SecureUIPanelTemplates.lua:55>

Locals: frame = 20
(*temporary) = nil
(*temporary) = 20
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = “attempt to index local ‘frame’ (a number value)”


#5

Sadly I think it’s safe to assume we haven’t if the play button is greyed out. Another thing you can try is manually opening the client (all the Play button does is open it + sign in) and sign in and see if the servers are available.

If it says “no realms available” - out of luck. Just another unintended teasing, I’m afraid :frowning:

A lot of the people that can even post on this forum aren’t actually able to test and leave proper feedback.


#6

Well, I created a Troll Priest…and it seems the Alliance side is like 80% Mages and is destroying us. As for bugs…haven’t noticed any since I’ve been dying too much. As for “fun factor” … I have the most deaths in this BG with 20 so far and getting destroyed by Gnome mages is not fun.

that said…it’s good to be back in old AV


#8

The problem is people are not playing their classes. Im a horde mage. I have priests soloing the other side. Stop!! Heal me! Im killing 20 to your zero. Dammit


(Fellína) #9

Well this is going to be the same in live anyway.


#10

My warlock didn’t come with a mount, why?


#11

Damn! I just got on the forums to post the exact same thing. Blizzard, blizzard, blizzard…oh crap…they found me! Icebolock. “Need a heal.” Priest attacks warrior.


#12

Rogues get 3 daggers, zero 1 h maces or swords. I don’t want to play a dagger spec QQ. The stormpike quartermaster inside the instance doesn’t appear to sell any reputation items? We start at honored with stormpike.


(Duman) #13

While I appreciate the premades, it would have been nice to be able to actually have healing gear for my pally (for example), or at least something slightly-better itemized for certain specs…

Any possibility of getting perhaps an “armor vendor” that has armor variants that could be useful for various specs? (Even make it so the items are soulbound when purchased, if there is concern about people trading gear or something silly like that)


#14

Yeah the option to play on the launcher is also not clickable for me :frowning:


(Kalfou) #15

I know it’s not Blizzards fault, but TukUI and AV seem to be incompatible, it’s throwing countless UI errors and actually crashed my whole system.

The Base UI is so rough though…


#16

Had an AV bug where despite having destroyed all of the Horde’s towers, their warmasters kept respawning on us.

Meanwhile after the Horde destroyed our own towers, our war masters stopped respawning.

As I recall, no towers is supposed to mean no more respawns. And both factions are supposed to be playing by the same rules, which didn’t happen in our matchup.


#17

In one of my games, I killed Galv and didn’t get any stormpike rep. I was the tank so I wasn’t out of range or anything.


#18

Are you a BETA tester on the BETA servers? If you are not, then you wont have the option.


#19

end our suffering please, no one deserves 3 days of this


#20

Thank you!


#21

Played 4 now. It’s a good re-creation of 1.12 Alterac Valley, but the problem is that due to the 1.11 changes both sides are always going to zerg. It’s just how players are going to treat it due to the return of honor vs time invested. I love the supplies for ground assaults and upgrading armor on the NPCs, but due to the dramatic reduction in NPC numbers from 1.11, they’re just red herrings. Those NPC guards that were removed made the zerg rush impossible. If you want to re-create the Classic Alterac Valley experience you need to go with the 1.10 or the 1.9 version, the 1.12 version is just modern AV without reinforcements and an extra 5 minutes at the end of the match while the adds are kited out and killed before the boss.


#22

Enemy Nameplate range seems to be super short. What is it like 15 yards? As a mage with spell range up to 41 yards this makes targeting difficult and targeting intelligently (prioritizing a target low on health) almost impossible as you can only see what you actually have targeted.

I’ve tried different name plate addons to address this problem and there was a nameplate extender that worked well early on in the beta, but hasn’t worked for a few weeks now. If anyone know of a working addon or script please share!!