Evoker Empower Skills

I’m using the Hold and Release empower hotkey set up and around 30% of the time it seems to not work. It will just charge the skill the full away even after I release the button. This seems to have gotten much worse after the expansion launched. I am not using a macro, just base casting.

It also seems to get significantly worse after using Dragonriding for whatever reason, could just be coincidence though.

1 Like

World of Warcraft Suggestions and Feedback
How to Report World of Warcraft Bugs


I’m looking for solving said issue, not reporting it.

No one would be able to do that for you. It would have to be looked at by QC to see if it is a bug and then they would need to implement a fix once they are able to figure it out.

1 Like

It won’t get solved if it isn’t reported.

1 Like

Reporting it was the first thing I did… now I’m trying to find a solution or find out if others have had the same issue. Seemingly this has been an issue since Beta.

Despite the report and other threads I don’t see it listed on this known bugs either.

Not everything gets listed in the known bugs.

Have you tried resetting your UI?

Yes, /reloadui, relogging, restarting and repairing the files and deleting. If you search on the forums you can find reports of this issue dating back to Beta.

The only thing you can do is file a bug report. Customer Support doesn’t take bug reports and the SFAs who post here aren’t liaisons with those that do.

Will do again and hope for the best I guess. Thanks for the responses.

1 Like