Crashing, freezing, and stuttering after 8.3 [Intel GPUs]

I’m running the game on a 2016 MacBook Pro and after downloading 8.3, the game crashes completely or will lag for about 5-10 seconds with the rainbow mouse icon circling. At one point, the computer shut down automatically after lagging. I’m using the most basic graphics and this issue particularly occurs when I’m around a lot of people or in a chaotic boss fight. I was told to switch the Graphics API to DirectX 11 Legacy and I’m unable to do that. The only option is Metal. Any ideas on what could solve this problem?


I am having the same issue. My computer will completely crash whenever I am doing the Heart Black Campaign quest line and you enter the instance in Uldum.


You’re unable to because directx is Windows only.


I see. Is there anything that can be done to fix the crashing and lag issue?

Blizzard has yet to acknowledge the issue, I haven’t seen any proposed fixes for mac besides user suggestions like turning your graphics down etc, none of which work


Having same problem, my MacBook Pro will keep freezing/crashing with 8.3. Can still play WoW classic without any issues so far!


When doing the quest for the Shroud of Resolve, I get into halls of origin with no problems… until I get to the light puzzle to activate the lift. That’s when it all goes downhill. The game locks up and makes me hard reset while halfway through the puzzle forcing me to stop playing altogether. I’ve reinstalled the game and still the same problem… anyone else facing this or is it just me?? I just downloaded catalina also…


Me too. I finally got passed it, but it happens all over uldum. I THINK there are a few other posts that might be referring to the same issue but I’m not sure. But I definitely have what you have. It just crashed me out of a bee event as well. So it’s not even uldum specific. But it’s definitely new since the patch. '15 MBP.

edit: I’ll add that I’m NOT on catalina (because I use CS6 products). So I’m still on Mojave.

1 Like

This happened to me about a dozen times before I gave up on the scenario. The light puzzle was where it started and then I restarted, the boss spawned, and I can’t even move.

It’s made the patch unplayable.


I’ve had the game crash my whole MB crash (basically a brand new one). Sometimes happens as combat starts but also randomly.

First it freezes and then it comes back in or my MB just restarts


Since 8.3 released today I’ve been experiencing in game freezes when I enter combat. They usually last for about ten seconds, and are completely random. Never had this issue before, anyone experiencing this? Currently running a 2016 Macboook Pro


Same thing on a 2017 MacBook Pro.


Same here … MacBook Pro, Catalina, all fixes applied

panic(cpu 2 caller 0xffffff801006520a): Kernel trap at 0xffffff7f91079bd3, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000001071898, CR3: 0x00000000168d1000, CR4: 0x00000000001626e0
RAX: 0xffffff8040e281c0, RBX: 0x000000000107188c, RCX: 0x00000000000fe918, RDX: 0x0000000000000001
RSP: 0xffffff9264c2bc20, RBP: 0xffffff9264c2bc40, RSI: 0xffffff8032cb4618, RDI: 0x000000000107188c
R8: 0x000000000000000a, R9: 0x0000000000000000, R10: 0x0000000000000000, R11: 0x0000000000000000
R12: 0xffffff9253f7fd00, R13: 0xffffff80108a2e60, R14: 0x0000000000000001, R15: 0xffffff8032cb4618
RFL: 0x0000000000010246, RIP: 0xffffff7f91079bd3, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0x0000000001071898, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 1

Backtrace (CPU 2), Frame : Return Address
0xffffff9264c2b680 : 0xffffff800ff3bb1b
0xffffff9264c2b6d0 : 0xffffff80100733e5
0xffffff9264c2b710 : 0xffffff8010064e5e
0xffffff9264c2b760 : 0xffffff800fee2a40
0xffffff9264c2b780 : 0xffffff800ff3b207
0xffffff9264c2b880 : 0xffffff800ff3b5eb
0xffffff9264c2b8d0 : 0xffffff80106d24f9
0xffffff9264c2b940 : 0xffffff801006520a
0xffffff9264c2bac0 : 0xffffff8010064f08
0xffffff9264c2bb10 : 0xffffff800fee2a40
0xffffff9264c2bb30 : 0xffffff7f91079bd3
0xffffff9264c2bc40 : 0xffffff7f930ce20c
0xffffff9264c2bc80 : 0xffffff7f93081dec
0xffffff9264c2bcf0 : 0xffffff7f93081c1b
0xffffff9264c2bd80 : 0xffffff7f9307d45a
0xffffff9264c2bdc0 : 0xffffff7f93081482
0xffffff9264c2be10 : 0xffffff7f9102c877
0xffffff9264c2be60 : 0xffffff7f9103a438
0xffffff9264c2bea0 : 0xffffff7f91039bf8
0xffffff9264c2bee0 : 0xffffff8010640ccd
0xffffff9264c2bf30 : 0xffffff801063f612
0xffffff9264c2bf70 : 0xffffff801063eb9c
0xffffff9264c2bfa0 : 0xffffff800fee213e
Kernel Extensions in backtrace:[9176E894-E24A-36BA-AFDA-0DB11F3F512A]@0xffffff7f91028000->0xffffff7f910ebfff

BSD process name corresponding to current thread: kernel_task

Mac OS version:

Kernel version:
Darwin Kernel Version 19.2.0: Sat Nov 9 03:47:04 PST 2019; root:xnu-6153.61.1~20/RELEASE_X86_64
Kernel UUID: C3E7E405-C692-356B-88D3-C30041FD1E72
Kernel slide: 0x000000000fc00000
Kernel text base: 0xffffff800fe00000
__HIB text base: 0xffffff800fd00000
System model name: MacBookPro11,5 (Mac-06F11F11946D27C5)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 50228689756279
last loaded kext at 49383565683627: com.vmware.kext.vmioplug.18.7.0 18.7.0 (addr 0xffffff7f960e1000, size 36864)
last unloaded kext at 50186805420972: >usb.cdc 5.0.0 (addr 0xffffff7f95efb000, size 28672)
loaded kexts:
net.lundman.zfs 1.9.3
net.lundman.spl 1.9.3
@filesystems.smbfs 3.4

AudioAUUC 1.70
@fileutil 20.036.15
AGPM 111.4.1
!APlatformEnabler 2.7.0d0
X86PlatformShim 1.0.0
!AHDA 283.15
@filesystems.autofs 3.0
!AUpstreamUserClient 3.6.8
@kext.AMDFramebuffer 3.0.4
@kext.AMDRadeonX4000 3.0.4
@kext.AMDRadeonServiceManager 3.0.4
!AGraphicsDevicePolicy 4.5.21
@AGDCPluginDisplayMetrics 4.5.21
!AHV 1
|IOUserEthernet 1.0.1
|IO!BSerialManager 7.0.2f4
!AThunderboltIP 3.1.3
eficheck 1
!A!IHD5000Graphics 14.0.3
AGDCBacklightControl 4.5.21
@kext.AMD7000!C 3.0.4
!ALPC 3.1
pmtelemetry 1
@Dont_Steal_Mac_OS_X 7.0.0
|Broadcom!B20703USBTransport 7.0.2f4
!AMCCSControl 1.13
!A!IFramebufferAzul 14.0.3
!A!ISlowAdaptiveClocking 4.0.0
!ACameraInterface 7.6.0
!AMuxControl 4.5.21
!ATopCaseHIDEventDriver 3420.1
!UTopCaseDriver 3420.1
!UCardReader 489.60.3
@filesystems.apfs 1412.61.1
AirPort.BrcmNIC 1400.1.1
!AAHCIPort 341.0.2
!AVirtIO 1.0
@filesystems.hfs.kext 522.0.9
@!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1
@BootCache 40
@!AFSCompression.!AFSCompressionTypeZlib 1.0.0
@private.KextAudit 1.0
!ASmartBatteryManager 161.0.0
!AACPIButtons 6.1
!AHPET 1.8
!ARTC 2.0
!AAPIC 1.7
$!AImage4 1
@nke.applicationfirewall 303
$TMSafetyNet 8
@!ASystemPolicy 2.0.0
|EndpointSecurity 1
Core!S 551
DspFuncLib 283.15
@kext.OSvKernDSPLib 529
@kext.triggers 1.0
@kext.AMDRadeonX4030HWLibs 1.0
@kext.AMDRadeonX4000HWServices 3.0.4
|IOAVB!F 800.17
!ASSE 1.0
@kext.AMDSupport 3.0.4
!ABacklightExpert 1.1.0
!AHDA!C 283.15
|IOHDA!F 283.15
|Broadcom!BHost!CUSBTransport 7.0.2f4
|IO!BHost!CUSBTransport 7.0.2f4
|IO!BHost!CTransport 7.0.2f4
|IONDRVSupport 569.3
!ASMBus!C 1.0.18d1
|IOAccelerator!F2 438.2.8
@!AGPUWrangler 4.5.21
|IOSlowAdaptiveClocking!F 1.0.0
X86PlatformPlugin 1.0.0
IOPlatformPlugin!F 6.0.0d8
@!AGraphicsDeviceControl 4.5.21
|IOGraphics!F 569.3
!AGraphicsControl 4.5.21
@plugin.IOgPTPPlugin 800.14
|IOEthernetAVB!C 1.1.0
!AHS!BDriver 3420.1
IO!BHIDDriver 7.0.2f4
|IO!B!F 7.0.2f4
|IO!BPacketLogger 7.0.2f4
!AActuatorDriver 3420.2
!AMultitouchDriver 3420.2
!AInputDeviceSupport 3420.4
!AHIDKeyboard 209
usb.IOUSBHostHIDDevice 1.2
usb.networking 5.0.0
usb.!UHostCompositeDevice 1.2
|IOAHCIBlock!S 316.40.3
|IO80211!F 1200.12.2b1
mDNSOffloadUserClient 1.0.1b8
corecapture 1.0.4
|IOSkywalk!F 1
usb.!UXHCIPCI 1.2
usb.!UXHCI 1.2
|IOAHCI!F 290.0.1
|IOAudio!F 300.2
@vecLib.kext 1.2.0
|IOSerial!F 11
|IOSurface 269.6
@filesystems.hfs.encodings.kext 1
!AThunderboltDPInAdapter 6.2.4
!AThunderboltDPAdapter!F 6.2.4
!AThunderboltPCIDownAdapter 2.5.2
!AThunderboltNHI 5.8.1
|IOThunderbolt!F 7.4.7
|IOUSB!F 900.4.2
!AEFIRuntime 2.1
|IOSMBus!F 1.1
|IOHID!F 2.0.0
$quarantine 4
$sandbox 300.0
@kext.!AMatch 1.0.0d1
DiskImages 493.0.0
!AFDEKeyStore 28.30
!AEffaceable!S 1.0
!AKeyStore 2
!UTDM 489.60.3
|IOSCSIBlockCommandsDevice 422.0.2
!ACredentialManager 1.0
KernelRelayHost 1
!ASEPManager 1.0.1
IOSlaveProcessor 1
|IOUSBMass!SDriver 157.40.7
|IOSCSIArchitectureModel!F 422.0.2
|IO!S!F 2.1
|IOUSBHost!F 1.2
!UHostMergeProperties 1.2
usb.!UCommon 1.0
!ABusPower!C 1.0
|CoreAnalytics!F 1
!AMobileFileIntegrity 1.0.5
@kext.CoreTrust 1
|IOTimeSync!F 800.14
|IONetworking!F 3.4
|IOReport!F 47
!AACPIPlatform 6.1
!ASMC 3.1.9
watchdog 1
|IOPCI!F 2.9
@kec.pthread 1
@kec.corecrypto 1.0
@kec.Libm 1


2019 MacBook Pro, same here, ever since 8.3 launch, 10-15 second freezes. Nothing helps, never had this happen ever before. Help blizz pls


Im having the same issue here, on a MacBook Pro 2017 13"


My graphics are fuzzy and my game is freezing as well. I bought this MacBook Pro on January 31 and it has worked incredibly with this game up until the patch today. It is definitely not my computer.


If the graphics are fuzzy try playing with your resolution in settings, it happened to me with the patch and for some reason it changed my resolution and it made everything look like crap until I switched it back. unrelated issue to the freezing though

I have already tried the fix for the fuzziness with the graphics. It didn’t do a thing for the quality of my graphics.

The problem is the patch. I shouldn’t even need to go in and do a fix.


Same. Experience crashes that last 10-30 seconds. Usually on bosses. Rare spawn sun king dude in Uldum is guaranteed to cause crash.

Looks like it’s not a Mac exclusive issue and could be due to a memory leak.


It would be great to get some kind of blue post confirmation that the issue is being looked into if nothing else