Constant WOW51900319 disconnects, game is nigh-unplayable

Like a lot of other people on this forum atm I’ve been getting kicked out of the game at seemingly random intervals since around the start of the latest Winter Veil event. I’ve been able to play around bad latency and such before but these are so frequent that I can’t do anything meaningful in the game anymore without brute force and lots of luck. As of this post I have tried the following, to no avail:

Removing my WTF, Cache, and Interface folders

Checking each add-on I use regularly in batches (from my findings D/C’s seem to occur no matter which combination of them are enabled at a given time but ElvUI and Tradeskillmaster seemed to exacerbate the problem as the D/C’s became noticeably less frequent when they were removed in particular)

Flushing my DNS and renewing my IPconfig

Restarting my router

Here’s the most recent WinMTR scan, also funnily enough the only one a disconnect actually happened during:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |

Host - % Sent Recv Best Avrg Wrst Last
192.168.1.254 - 7 818 764 1 11 619 2
75-46-232-1.lightspeed.tukrga.sbcglobal net - 9 782 719 1 18 201 2
107.212.169.242 - 9 778 713 3 19 196 4
12.242.113.159 - 10 747 675 4 17 318 5
12.247.68.74 - 6 842 794 5 26 611 7
ae1-br01-eqat2.as57976 net - 9 766 698 25 49 401 26
et-0-0-4-br02-eqch2.as57976 net - 7 817 763 25 42 255 28
be2-pe1-eqch2.as57976 net - 8 802 743 0 47 334 26
chi-eqch2-ia-bons-02.as57976 net - 7 814 758 25 49 338 28
24.105.62.129 - 8 810 753 26 49 371 28
________________________________________________ ______ ______ ______ ______ ______ ______

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

If anyone has any ideas they can throw out, I’m all ears. I’ve been itching to do Nyalotha with my guild ever since October and this sign that I’ll have to skip the tier is heartwrenching.

1 Like

When ingame, were you getting any weird zoning issues at all? Like instance transfer aborts leaving you stuck half in one zone unable to mount up and move along? With the acceptation of what I mentioned above, im having this exact same issue.

1 Like

'Fraid not. The strange thing is WoW seems to still work perfectly fine both mechanically and latency-wise besides these disconnects, no other game (including other blizzard titles) does this, and, being the only person actively using the network at the moment and it still occuring, I think I can rule out it being an issue with network crowding too.

I’m going to try power cycling my router, repairing my WoW client, and checking if it’s my KB/M as recommended by this GM post roughly a week ago: Can't Submit A Ticket For A Connection Issue

I’ll report back later in the day with results. Wish me luck!

Hey there,

Are you using a wifi connection by chance? Your WinMTR is showing some pretty major packet loss (7%) and high latency spikes (619ms) between the PC and router. The packet loss and latency carries down the test since it’s starting at the router, which means it’s going to affect everything else downstream.

If you are using a wired connection then there may be an issue with the router that may need to be checked out by the internet provider.

1 Like

Back, here are my findings:

  • The repair scan only lasted five-ish minutes so I assume it either couldn’t find anything broken in my files or whatever did get fixed was too small to be of any impact

  • Power cycling did nothing that I could find.

  • Switching over to a different keyboard and mouse seems to have had an effect. I’m still testing in different zones/situations but I haven’t gotten a D/C thus far. However between this test and after power cycling I went AFK to make some lunch and got another Disconnect in my absence, so I’m taking this approach with a grain of salt until I can get more conclusive results.

Hey there,

Are you using a wifi connection by chance? Your WinMTR is showing some pretty major packet loss (7%) and high latency spikes (619ms) between the PC and router. The packet loss and latency carries down the test since it’s starting at the router, which means it’s going to affect everything else downstream.

If you are using a wired connection then there may be an issue with the router that may need to be checked out by the internet provider.

I’m on wifi, going wired isn’t an option as there’s two stories between my router and PC. Is there anything I can do about that lag between the two? My ISP has proven to be unreliable with this kind of thing in the past so I’d prefer to only talk to them about this as a last resort.

Suggest trying Powerline Ethernet Adapters. Uses the copper in the house to transmit your internet.

Totally making a mental note of that when I can drop the cash, but AFAIK those won’t do much in this case. My connection was fine until late November-early December without any changes. Besides, as I’ve said this is only for WoW. Every other game still works just fine.

Heya,

Unfortunately we aren’t going to be able to help much more unless you can swap to ethernet. While I totally understand that in some situations an ethernet cable is not an attractive solution, with 7% packet loss between your PC and router, this behavior is expected. Other than corrupted game data (which would have been fixed by the reset UI which you already did) there’s not much else which would explain the problem you’re having.

If you can temporarily move your setup and test via ethernet cable/re run the winMTR test and catch a disconnection, we might be able to see if the problem is actually router level and not just a wifi thing, but as long as you’re getting this kind of packet loss our hands are tied.

Shucks. Alrighty, I’ll grit my teeth and try to get it done over the weekend and report back as soon as I can then.

I’m trying to troubleshoot this issue as well. I feel the pain. Same issues, same tests to find a solution, so far I’ve got nothing. Not sure what else to try…

So you also have a poor connection between your computer and your router? At least read a thread to see if you actually share an issue instead of just reading the title and posting. If you really have done some testing you should post it in your thread.

I did state that I had a shared issue and that I tried the same testing with no results. That’s what the word “same” in English means. You can tell someone something without being superfluous if your situations are relative to one another. It’s sympathizing and bringing light to a situation in a minimal way. Go be annoying somewhere else

I think I’ve found the issue! (Or at least a major contributor to this madness)

I have Discord open almost 24/7 alongside other stuff nowadays, WoW included. I decided to look into its settings on a whim and outright nuked the game activity tab, unchecking WoW and removing everything else from the listings. Lo and behold, I managed to get nearly two and a half oh-so-wonderful hours in doing Uldum quests with the bois!

I’ll keep on for as long as I can to make sure I’m not just being strung along by the outright evil netcode but this is definitely a good sign! I’ll report back once I’m satisfied/if the D/Cs rear their ugly head again.

Interesting! That might consume less bandwidth which COULD make that packet loss less impactful - replying back so you can keep us posted in case you need more help. If it comes back, just get back with that on-ethernet test and we can look it over together and see if maybe we should have you tell your ISP to send you a new modem or something like that.

FIXED, at least for me.

ipconfig /release
ipconfig /renew
ipconfig /flushdns
Windows Update

I can’t tell which one fixed my issue, but it fixed it.

Hey all, sorry for the delayed response on this. I forgot about this at first, but I also updated my wifi adapter’s drivers a bit before I messed with Discord, so it could have easily been responsible for improving things also. Anyway onto the good news: Over the past 24 hours I’ve had a grand total of only 2 disconnects, a massive improvement over before. To go into detail, they were:

  1. At the start of my day doing activities in Vale. (The whole zone was laggy as all get-out though so I can easily just pin that one on my internet/as a seperate case from the more random ones)

  2. During a run through Normal Battle of Dazar’alor, specifically right at the start of fighting Conclave of the chosen.

I admit that I get a bit key-spammy during longtime encounters, and curiously enough I’ve also noticed quite a bit of “Jittering” when moving sometimes, namely when I’m changing direction mid-run. Between these two, I’m starting to suspect my keyboard and mouse again, so first thing tomorrow I’m going to do more extensive testing with my setup, and run another WinMTR scan to see if there’s any changes in it after all this troubleshooting.

Sounds good,

Replying again so you’re able to report back with your findings.

Okay, things have officially gone from bad to AAAAAAAAAAH in the span of a day.

To start, I did three keys with my guild: A 10 King’s Rest, a 10 Waycrest Manor, and a 15 underrot. Two disconnects happened during the King’s Rest run so I took a break, updated my mouse’s firmware/drivers (Logitech is vague about it, I’m unsure which), and went into another two keys to test the waters then. Interestingly enough I experienced three lagspikes that all-but seemed like they were going to be disconnects, but my client managed to catch back up on all three occasions after a few seconds. I entered a warfront afterwards only to be met with the same kinds of freezes three times in a row before even getting off the airship, it seemed like I made some kind of “quality for quantity” type deal with the mouse update, maybe it was a plus, maybe not…

Then Windows slapped me with a “kernel_mode_heap_corruption” bluescreen.

To say the least, I freaked out and immediately went for troubleshooting it above all else. Updated my graphics card drivers, ran the System File Checker and dism . exe to make sure my OS wasn’t corrupted, both scans came back with nothing to report.

Then, to make things worse, updating my graphics card also meant installing AMD’s new radeon software, which, for future reference does not play nice with WoW at all. Scrambling through said warfront I had to deal with my game freezing up if I had it as the primary window for more than two seconds at a time, on top of the prior lagspikes. I ended up having to disable darn-near everything the app had on by default, including the game overlay, every keybind, and a ton of excessive settings like picture sharpening, FPS limiting to save power or whatever, the works. I don’t have the time or patience anymore to test which specifically caused that madness but if anyone ever hits up support over this issue here’s a good starting point for troubleshooting it.

It’s probably a HUGE risk on my PC at this point but I’m going to give stromgarde another try or three momentarily and report back with a WinMTR copypaste when/if I get another lagspike/DC. In the meantime here’s one from the start of to roughly the midpoint of key run #3. I should preface I was not able to move my setup over the weekend like I hoped:

|------------------------------------------------------------------------------------------|
| WinMTR statistics |

Host - % Sent Recv Best Avrg Wrst Last
dsldevice . attlocal . net - 2 1970 1931 1 4 116 3
75-46-232-1.lightspeed . tukrga . sbcglobal . net - 2 1976 1940 1 12 2701 5
107.212.169.240 - 2 1988 1954 3 10 207 5
12.242.113.31 - 2 1990 1957 4 13 1448 6
12.247.68.74 - 2 2019 1993 5 16 433 8
ae1-br01-eqat2 . as57976 . net - 3 1962 1921 25 35 214 28
et-0-0-4-br02-eqch2 . as57976 . net - 2 1983 1948 25 43 1275 27
be2-pe1-eqch2.as57976 . net - 2 1988 1954 25 33 207 28
chi-eqch2-ia-bons-02.as57976 . net - 2 1984 1949 26 35 223 28
24.105.62.129 - 2 1972 1934 26 34 227 27
________________________________________________ ______ ______ ______ ______ ______ ______

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Elandreth I’ve been having the EXACT same issue. It feels almost like im getting stuck between phases. My chat works but my world server connection goes to heck and everything disappears. Game works fine on my cell phones connection but my ISP Sparklight this has been going on since November. Ive tried wireless, ethernet, switching modems, having ISP check my lines…nothing works

Welp, no progress to report today. Disconnects are still happening at a 2-3 a day-ish basis. After the bluescreen I’ve spent today narrowing things down and checking if any programs have been conflicting with WoW, and AFAIK I haven’t made any noticeable progress in that front, I’ve also checked the event log for anything incriminating but haven’t found anything I can make sense of or lines up with my problem. I do at least have a new lead. I checked the logs on my router shortly after a DC and found something interesting: A handful of “Invalid IP Packet” messages coming from my device. Any idea what this means or what I can do about it? It’s lining up very well with my issue but, again, I’d really rather not go to my ISP for this unless it’s my absolute last resort.

On a side note, I should be able to get my PC moved close enough to perform a wired WinMTR test later today. Anything specific I need to do for it?