Conduits still not working properly

This happens every time you log in. Soulbind paths break and conduits that were taken are now greyed out and unusable because the game believes that another path was taken, when in fact; the path has not changed.

As you can see by the lit up conduits on Niya, my path goes from the top left, down through the middle, and to the right, and only the set in stone covenant conduits are able to be chosen/used.

This time around in build 35755, I can’t change my path to force the conduits to reset and test the conduits. Therefore soulbinds, at least for me, are just broken and unusable/untestable.

Would like to see this issue addressed so that these are actually accounted for when tuning comes around.


Have the same issue on both my premades on the Torghast realm. However they’re Necrolords so I guess that means it isn’t limited to that covanent. One character had no conduits activate the other is stuck with only a couple of slots near the bottom activated.

I understand beta is beta but we haven’t even heard an acknowledgement of the issue for over a couple weeks now and i’m starting to worry something like this might not be caught in time for release.

+1, also still broken.

Still broken for me as well. Haven’t figure out a way to totally reset it.

Nadjia the Mistblade’s tree isn’t working at all, not granting any passives and no conduits in the tree are working. Every Soulbind I have is doing the same thing as OP but Nadjia is extra broken.

Before this build we could change paths around and it would re-activate the broken links but nothing seems to fix it now.

It’s all good folks, they have plenty of time in the next… //checks calendar//… 7’ish weeks …//shudders//… to fix this and everything else.


Yeah the old work around doesn’t even work anymore so its even more annoying. I dont want to keep creating characters just so I can test my conduits for like an hour. This is stupid and frustrating.

still not working as of 9.0.2 by the way

Same issue as the other posters.

Same issue and all my guildies have the same issue. Soulbinds and conduits have basically never worked properly for more than 2 hours

I too have this issue.

I’m having this exact issue as well. I believe the conduit specific powers are working, the “random effect ones.” However, none of the class-specific conduit abilities are working. They are all grayed out. It also doesn’t show an active path that I’ve chosen. I tried resetting the tree, clicking each individual node, etc. Nothing worked. Didn’t even realize until I looked at my Ice Block and saw that it was a 4 minute cooldown, instead of 3.5 like it should be with a conduit I have applied.

Having the same issue. When I first set the conduits and the path, I got all the bonuses, (using Nadja the Mistblade, Venthyr Soulbind) and now I get none of the conduit bonuses themselves, only Nadja’s initial passive bonus.

1 Like

Voicing the same problem. Glad it’s not just me. I had tried testing and streaming for my guild to show how conduits work, and it’s impossible currently. Needs fixed so we can properly test.

1 Like

Throwing my concern in here as well. Resetting the conduits doesn’t seem to reset everything. Either the system is broken or the UI is. This is with respect to my characters on Torghast. I’ll see if the same issue exists on Oribos later.

Edit: not working on my Oribos 60 either.

1 Like

Same issue, conduits and paths are broken. Resetting weekly doesn’t reset paths so it remains broken week after week.

1 Like


A few minutes ago, we applied a hotfix to the Shadowlands Beta that should prevent testers from getting into this broken state.

It should also reset the soulbind tree for test characters that were in the broken state.

Thank you for the bug reports!


how about a hotfix for [Ritual of Purification] the night fae quest line, so that the npc is there and doesn’t just randomly die and never respawn ?

1 Like

Thanks for the update however Kyrians can’t move past their 1st soulbind option as Pelagos disappears in the middle of the quest. Can’t complete.


On my toons where I already have Pelagos, I can now actually fill out my soulbind / conduits again. So that part is fixed. However, Pelagos still de-spawns at the exact same point on toons where I’m trying to get him as a soulbind for the first time.