Cant use oribos portal

I have a few level 50s that I wanted to finish leveling in shadowland the first few are working fine but that ones I tried to start today in chromie time are not I can take the shadowlands option from her but when I try to use the portal its there but I cant use it . From what I can tell the ones that are not working I didn’t start that shadowlands quest line there at all


When you talk to Chromie & select Shadowlands, you should get a quest to see Darion Mograine in front of Grommash Hold. When you get there, talk to Nazgrim & view the cinematic. After that, you can either take the death gate opened by Darion if you want to play through the intro, or you can talk to Nazgrim & choose to skip the intro in which case he’ll teleport you straight to Oribos.

Hi thanks for the reply I do talk to chromie and select shadow lands but im not getting any quest on any toon and the ones that worked yesterday also did not get a quest but the portal worked

That’s how it worked on a fresh level 10 character. And when I tried it on a level 45 character I hadn’t played in a few years, she also got the quest from Chromie. Neither one of them could use the Oribos portal, though - I’m pretty sure that doesn’t work until you’ve already been there.

I checked a few level 50 toons but they already had the starter quest so I must have logged into them sometime after Shadowlands launched.

I’m not sure what to suggest - maybe check to see if Darion & Nazgrim are hanging around in front of Grommash Hold?

Yep just looked around for them but no luck , no idea why its not working I’ve tried 4 now and I’m getting the same thing .Thanks for trying :slight_smile:

As an experiment, I tried starting the intro quest on a character & then hearthing out after I got to the Maw to see if I wound up locked out of Shadowlands like your level 50s, but there was still a way back. The Oribos portal in the portal room remained non-functional, but Darion’s death gate was still standing outside Grommash Hold and it took me right back to the Maw.

Ive also done a bit of testing , if I take any other timeline I get a quest only the shadowland one fails to give me one . So frustating

Did you try a mage teleport? That’s one option that didn’t occur to me until just now.

no not as yet but I did find out all of the toons that haven’t been to shadowlands cant take the chromie quest to get there