Can't spend Honor cause "The Battle For The Undercity" Quest bug

If any don’t already know, trying to do this quest will bug you out and you will not have any NPC’s in Org or UC. I can’t even spend any honor in Org, meanwhile, people are buying deadly gear and then farming even more.

This needs fixed urgently.


Bump. Any workaround that someone has figured out would be appreciated.

1 Like

I know this don’t help any but I remember doing the quest a bunch years ago and never having any issues with it bugging up.

So for those tracking this thread. The battle works for me and anyone i’ve talked to who has done it in the last ~5-10 hours. It seems very buggy and is fixed with multiple bandaids, but you can get the quest done to fix orgrimmar. Takes about an hour.

In order to finish this quest prior to their fix, get a group and kill the last boss without the aid of the quest and it will push the quest completion through.

Oh my god… I can’t finish the quest too, I just gave up with it, didn’t realize this could happen if you main a horde…

i finished mine by killing last boss with a group; UC and Org are back to normal

It either works or it doesn’t. If its broken for them they are broken and can’t do the quest.

Mine was broken, just manually killed boss without help of quest and it progressed like normal even though some npcs didnt spawn

To everyone saying just kill last boss, for certain players it’s bugged and you can’t even reach the last boss because the entryway is blocked with stones. Keep coming with your ideas though lol

1 Like

There is a window where the throne room becomes accessible. Wait for the event to reset and follow thrall the entire time. It’s worked for everyone I know who has tried it for the last two days. Streamers are saying it’s working for them too.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.