Can't log into

When i try to log into Battle-net won’t let me enter my password and i’m getting an error box. I tried to click the error link for more help but it takes me to a page that won’t load.


Same here friend.

Same here as well.

1 Like

It won’t log me into the game if i try to enter offline either. :confused:

Yeah, it’s annoying :frowning:

cant log in, all i get is the you have been disconnected (blz51914003)

1 Like

Same issue here.

Battlenet App does not even let me enter my password.
Error code is, BLZBNTBNA00000A8D

Funny thing is, if I change the region from Americas to other regions in my Battlenet App,
it displays the sections to enter my ID and password without any issues.

So is this a NA only issue?

EDIT: If I try to login from WoW directly, I get the same error code BLZ51914003 as Darthvixen above.

1 Like

several attempts to logging in then disconnected (51914003)

I have WoW on two computers (different accounts) and strangely, I can log in one one computer, but not on the other. I get the same error message as above, “could not log in to Battlenet”, more help: BLZBNTBNA00000A8F (2700). (the more help doesn’t link top anything)

I just retested, and if I choose “Asia” as my region, it logs me into the game, in North America.

1 Like

Very same issue here.

Thank you for the post, I was able to log in after trying this.

1 Like

Cannot connect directly with Classic client BLZ51914003…
Won’t connect via Battle-net app BLZBNTBNA00000…
Continue offline with Battle-net, get some update option (guessing for Retail). Messages saying cannot connect. Safari says cannot make a secure connection with nydus-battle-net…

Going to try Asia option

1 Like

huh… I can log in also… thanks? :smiley:
edit: asia option works!

where is the option to switch to Asia at ?

ironically, i am playing form Philippines which is closer to Asia than Americas

On the Bnet launcher (like when you click on the icon at the desktop), there’s a little drop-down on the upper…ish left side just above the email entry.

Switching to Asia and using Battle-net launcher to get into the game works as a work-around. Still would prefer to be able to use the client to launch…

I am unable to connect to Battle-net

Asia option worked for me

I changed my region to “Europe” in the Battlenet app, logged in with Battlenet app and launched WoW from there. And it actually worked.

Is this how its suppose to work?
I thought I would be able to login to Battlenet but not WoW since I don’t play on EU servers. But it logged me in to my NA WoW account and can see all my toons…

I guess its the NA authentication servers which are having issues.

1 Like

I also cannot figure out how to change to Asia/Europe authentication server. Where is this option?