Cant get to open

ive done all the things! closed programs, disabled security, reinstalled battle .net…

no matter what i do, its the same: the login window takes a long time to pop after starting, and then after entering credentials, and apparently passing that step, the window disappears, but the actual app does not then appear, even tho i can see it in the task manager spinning cpu cycles…

and it happened, like literally overnight; shut down for sleep normally, woke up and it didn’t work… and no, windows did not update during that time, so, shrug.

also, if i bypass and just load from the game .exe its all good!!! Heck i’d still be doing that right now if it wasn’t for the content update i cant get cuz wont work

anybody got any ideas? im at my wits end

Disabling security apps that aren’t properly whitelisting the Blizzard services may not be sufficient to prevent them from blocking the app.

Please make sure to include your DxDiag for troubleshooting :slight_smile:

I too can not connect to bnet,

Heres that DxDiag
https:// pastebin. com/FTNUKTB5

Try disabling this:

Problem signature:
P1: Microsoft.XboxGamingOverlay_5.420.11102.0_x64__8wekyb3d8bbwe

In DxDiag? I have all the option in Window’s 10 ‘Gaming’ section turned off.

The error is from the DxDiag provided in your previous reply. The gaming bar is turned off in the Control Panel.

I googled how to turn off ‘Microsoft.XboxGamingOverlay’ and the steps in the guide I already have done. Settings, Gaming, ‘Game Bar,’ and it’s already set to off-

Hello Elocin!

here’s that file https:// pastebin. com/ GC9gjE5s

as to troubleshooting… shrug, i followed instructions related to issues. nothing worked

i can see both battle. net and the agent spinning cpu cycles and sending/receiving data over the internet via task manager. i can log in via game.exe so i know its not a connection issue.

all drivers and os up to date.


i can log in via game.exe,

I logged in and it asked for my auth code, no login attems but the manual code worked; Also then my bnet came back up

i just shut off the xbox overlay: still no luck.


I see a crash from the GPU but it doesn’t tell me what’s causing it. I also see a crash for Logitech’s SetPoint.exe application, so you may want to reinstall it.

Do you have Avast/MalwareBytes/something similar?

Hey Belicos,

Can you try closing the app completely in the taskbar at the bottom right, then unplug your external monitor and then try launching it again? See if it will show up properly on the built-in display on the laptop.

Your current desktop resolution is showing 1366 x 768 as well, but the native (default) resolution should be 1920 x 1080. Double check that by right-clicking anywhere on the desktop and going to Display Settings, and see if changing the Display Resolution to 1920 x 1080 helps.

Elocin, i’m using stock win10 security for the moment; its a brand new computer

hi Jambrix! thanks for the response.

i did all your suggestions and it worked!

(i also uninstalled setpoint and did not reinstall it yet- i think i had the 32 bit version dunning :confused: )
and, windows updated last night, so there’s that as well…

why would unplugging the second monitor help? i still had the laptop monitor set to “primary”

all’s well that ends well!

Glad to hear that helped. Best guess is that the app was trying to display on the other monitor but couldn’t for some reason.

With the app open you could try plugging the secondary monitor back in and then click and drag the app over if you want it on that other monitor.

Best of luck!