Can't Enable DirectX 12 in WOW

Ah, I’m running Windows 7, and it doesn’t support DX12. So that’s probably the reason for me :frowning: Not sure about OP.

Its not miss information its a fact Yes new drivers will still work on them but they are not adding new features for any card that is 600 series and below. Most of the 700 series are just Kepler refresh and also will not run wow the exception is the GTX 750 TI which is a Maxwell chip.

Most
List of fermi GPUS there are 400-800 series in the list
https://nvidia.custhelp.com/app/answers/detail/a_id/4656/~/list-of-fermi-series-geforce-gpus

List of Kepler GPU’s
https://www.geforce.com/landing-page/graphics-cards-with-kepler-architecture

These are the Maxwell GPU’s and are should run wow in DX 12

1 Like

Have you checked to see if you are running wow in compatibility mode.

A 750 TI is a Maxwell card and shares the same GPU as the 900 series. All of the other 700 series cards and below will not run DX 12 in wow as it is missing the required feature level in the GPU.

I realize there are a lot of people with older cards that support the DirectX 12 API even though they cannot do so entirely in hardware, which means WoW will not run in DirectX12 mode. And I appreciate and understand their frustrations; but to the potential posters and the Blizzard respondents, can we please keep this thread on the rails from which it was created?

There are people that are 100% DirectX 12 hardware compliant that are having a software issue, most likely related to an interaction with Windows 10 user accounts and/or some other factor.

Let’s keep this one on topic, please. There’s plenty of forum space to go around.

5 Likes

This is true. If you launch WOW from wow.exe as Admin, Directx 12 option is there.
I made a new admin user on my PC and the Directx 12 option is there even when you launch from battlenet.
Is there a way to fix my “normal” admin user that i used since my last windows installation?
Edit: my card is a gtx 970.

@ Druidagorda Try this see if it works let me know there are a few other thing to try to fix your admin account

  1. Insert the Windows 10 Installation Disc and restart the computer (If prompted, press any key to start Windows from the installation disc.) If you do not have a disc create one from this link on another computer:

http://windows.microsoft.com/en-us/windows-10/media-creation-tool-install

  1. Click on Repair your System.

  2. Click on command prompt

  3. Type the command below and press enter.

net user Administrator /active:yes

Restart the computer to login to admin account.

Note: Disable the built-in account after performing the troubleshooting using command:

net user administrator /active:no

1 Like

Thanks for the help. Using the admin account gave me the directx12 option.
There was clearly an issue in the main account that i been using.
I did not have much information on my pc, so I proceeded to format it generating a new user.
With this new user I have the option of directx12.
I hope that others have a less drastic solution than mine xd

This is extremely disheartening. I was really looking forward to this, especially since I am running DX12 in Windows 10. I wish they would have been more clear about limitations, despite being compatible.

Was having the same issue of only being able to enable dx12 on my 1070 by opening wow outside of the battle.net client. Disabling compatibility mode via battle.net windows properties and adding in the command line -D3D12 in the client were able to fix this for me would recommend trying both.

2 Likes

I have been experiencing the same issue here. Just a note for troubleshooting / FYI: If you run WoW.exe from the World of Warcraft folder as Administrator, DirectX 12 is an option and works fine. Changing the setting will persist through closing the client and logging back in as Administrator. Once you open the client through the launcher, the client will revert to the DirectX 11 only case in the original post, rewriting config.wtf to SET gxApi “D3D11” upon exiting the client.

Here is my the head of my DxDiag (couldn’t figure out how to put it in it’s own scrollable block):

THIS x1000!!

I get the DX12 option when running directly from the WoW.exe, and not through the launcher. It’s reverting itself back to DX11 as Odywon pointed out. It’s annoying to go through the WoW.exe every time instead of the launcher though.

Thank you for this! I guess I won’t be using Bnet.

Thank you so much, Reinea.

Literally just fixed this on my son’s computer with the same issue. Removing all the compatibility mode entries from the registry did the trick. The location is below.

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

I removed anything/everything related to Blizzard, Bnet, WoW, etc.

6 Likes

Same thing on AMD 7790, so not just Nvidea.
To clarify, I can see the option and it tells me to restart, but it goes back to DX11.

@ Aldric
Without looking at your DXdiag sounds like in your case the change is not saving or a driver issue.

Thank you!! This worked for me as well. Now I can run WoW from the Launcher instead of the WoW.exe for Directx12!

Brilliant! That fixed my issue as well. Bravo!~ (I’d insert the ‘Citizen Kane’ slow-clap gif if the forums permitted such shenanigans)

There are a bunch of different issues being reported here at the moment - and we’re also doing some digging into the DirectX 12 issues on some cards. Here’s some more information on what is needed to run DirectX12 on wow’s engine however, for the technically curious.

  1. Windows 7 or 10 is required for DirectX 12. For windows 7 users, ensure that your windows is completely up to date as a new update was released in March of 2019.
  2. The video card must support Tier 3 or higher Resource binding. This means that your GPU has to be on par with or newer than these architectures:
  • AMD: GCN 1
  • NVidia: Maxwell
  • Intel: Skylake
  1. Your graphics drivers need to be fully up to date.
  2. You must NOT be running the game in Compatibility Mode - setting the app to compatibility mode may make it think you are not running Windows 7 or 10 which is requirement 1 for DirectX.

If none of this works, but your PC meets the above requirements, follow the steps in this post to force DirectX 12.

If your directX 12 keeps reverting after running the game as admin, there’s probably something up with your registry or admin permissions. I don’t recommend modifying your registry as Abefroman mentioned, as doing this incorrectly can result in system instabilty. Try creating a new admin instead and see if it works there. The new admin creates a new set of HKEY_CURRENT_USER registry entries without you having to deal with regedit. If you’re an advanced user you can mess with the registry but do so at your own risk.

If you’re still having trouble after trying these steps, I recommend you create your own thread or contact support. This’ll be too complex to troubleshoot all of your errors in one thread.

3 Likes