Boots of the bay teleport not working

Won the fishing derby today and selected the boots as my reward and when I tried to use them to port to booty bay they start casting then stop… Thought maybe it was because I was in outland when I tried but nope even in Northrend and even Eastern Kingdoms they still dont work

2 Likes

Same for me, they worked flawlessly the first time (6 days ago) but now they are bugged it seems. RIP.

1 Like

just won them today and was so excited, still doesn’t let me cast. so frustrating.

Confirmed still not working 11/1

yup was just about to post this

mine are also not working

:frowning:

Can confirm that they are not working for me either, like it thinks each cast is interrupted

Hey blizz, fix yo stuff

Bump, still broken. It seems to be due to the spell requiring “8% of base mana.” In retail, this spell was fixed to remove the mana cost. In classic, the mana cost is still present. Look up spellID 71436 on WoWHead.

Actually, that isn’t the reason. It’s because the spell requires you to be Alliance to use. See how everyone posting in this thread is Horde? Not a coincidence. Removing the faction specific flag for the spell should cause it to work again.

Figures that it would be broken only for horde, blizz not testing for horde has been a meme since vanilla. Still broken btw.

Just won today and still not working.

Any chance this’ll be fixed in the ulduar patch?

Nope still broken.

Here we are in phase 2 and these are still broken