Blue Screening

Since I resubbed to wow recently after a few months of a break, I’ve found a weird issue that just now has came up. (This did not happen with 8.3 when I left, so I don’t think its the patch’s fault.)
For some reason whenever I press play, there’s a coinflip between actually loading the game, or flashing both my computer screens on and off, and then bluescreening my computer.
I’ve already tried moving files to a different SSD, repairing, and reinstalling, but not sure what else could be the issue other than a graphics card error (which is a GTX 1660-Ti, barely a few months old)
Any takers?

I’m having the exact same problem. No idea why - also, can’t locate my game files immediately after a fresh installation and subsequent blue screen.

I actually found a (possible) fix that’s worked so far.

  1. With the desktop app opened and WoW selected click on Options
  2. Select Game Settings
  3. Find WoW and check the box for Additional command line arguments
  4. In the new box enter the command for the desired DirectX version:
  • -d3d11legacy
  • -d3d11
  • -d3d12
  1. Click Done to save.
    This is from their website. I’m wondering if something with windows 7, some nvdia GPUs, or something is having issues with dx12. I just bumped down to 11, and so far no other breaks.

Thanks, that seems to work for me as well! Really appreciate you following up on this.