Battle.net launcher can't locate game

I’ve been trying to launch WoW through the Battle.net launcher, but it’s indicating I need to install it first (for retail, classic & tbcc beta). Worked fine at every other point, until today. Clicked “Locate the game” & went to it, but message states “This folder doesn’t contain the correct version of this game. Please check the installation path and try again. ‘More help: BLZBNTAGT00000AF0’”. I followed the troubleshooting tips indicated for that error code, but launching directly from the game folder didn’t resolve any configuration errors. Followed suggestions from a similar topic & uninstalled/(clean) reinstalled the launcher (twice actually, temporarily disabling Norton the 2nd time just in case), still nothing. In the launcher settings I went to Settings>Downloads & ‘Scan for Games’, but after I path it there, nothing for WoW shows up on the list. I even went ahead & clicked “Install” to see if it’d recognize it was already installed & maybe just update, but it’s indicating I need 74+GB & don’t have enough space (which is true… I need to get a new laptop. Yes, has to be laptop, no place to setup a desktop). Given issues I already have with the computer, it’d take hours, or even a few days to uninstall & reinstall the games.

I recall a message popping up last night that Battle.net updated & needed to restart, and now today it can’t see the game. Seems that update would be the most likely cause. I’ll continue launching it from the game folder for now, but would like to know if there’s a way to manually reconfigure the launcher to recognize the game is, in fact, already installed. Or, if the last update to the launcher can be reviewed to see if there was an unintended oops.

Hey Laryssa,

That’s a lot of problems going on with World of Warcraft basically not being recognized by the Battle.net application any longer. With what you describe for this starting, I suspect something may be corrupted with the Bnet app itself. A regular reinstall of it may help, but I’d like to be thorough and nuke all traces of it before reinstalling to see if it will then let you locate World of Warcraft. This goes further than what a normal uninstall does as it gets rid of files that can linger. Steps for this are:

  1. Uninstall the application
  2. Press Windows key + R and type in %temp%
  3. Delete anything related to Blizzard or Battle.net
  4. Do the same for %programdata%, %localappdata%, %appdata%
  5. Reinstall the application! - https://battle.net/account/download/index.xml?show=bnetapp

Followed the steps, also ran ccleaner & went through the registry (not suggesting that to anyone else, lol) before reinstalling to make sure any fragments left behind were cleared out, but no change. The game will run launching from the game folder, but Bnet still isn’t recognizing those 3 are installed. When I first installed on this system, it created the World of Warcraft folder, and within that ‘_classic _’, ‘_classic_beta _’, and ‘_retail _’. Is it possible something changed in the last Bnet update, so it’s looking for a different file name? The PTR landed in a separate folder, as did other games, and Bnet is seeing those, so I don’t know if the folder name would have anything to do with it :woman_shrugging:

same problem here

also done the file sweep and uninstalled and reinstalled the app … still unable to locate

Been more than 2 weeks now, and Bnet still isn’t recognizing WoW (retail, classic & tbcc beta). Uninstalling/Reinstalling Bnet hasn’t worked. Since the game runs fine launching it from the game folder itself, that would indicate it isn’t an issue that’d necessitate uninstalling/reinstalling the games. Any word yet on a fix for this, or is it even being looked into? This all started after the last Bnet update. Is or will there be an update soon to the Bnet app, or a way to roll it back to the previous version? Right now mine shows Bnet version 2.0.0.12862, and update agent version 2.24.2.7380.

yeah this is kinda annoying… wish someone from blizz would do something about this crap

You mentioned you disabled Norton, did you try uninstalling it?

No, but it was never a problem prior to the Bnet update done on 5/4/21. The update on 5/13/21 didn’t fix the issue either. Since the game runs fine launching it from the game folder, and was never an issue before, it has to be something that was changed in Bnet.

This is the clue Laryssa. I suspect the Agent.exe was updated that day. Antivirus often flag that. Odd thing is this issue will only occur on some systems. Antivirus has a AI of sorts and for some reason yours may not like the new Agent.

Disabling antivirus usually doesn’t work - nature of the beast. To test things they need to be completely uninstalled. To do that properly you would want to check Norton support. There will be a tool for your specific installation.

Windows Defender takes over the instant a 3rd party Antivirus is uninstalled.

While this may not be the answer we need to rule it out.

Im also having this issue. All the other versions of the game are fine besides classic vanilla. Had no problems playing last night.

1 Like

same…what is going on

I’m sure Norton isn’t the issue, as the game runs just fine launching from the game folder. If it was an issue with Norton the game wouldn’t run, and in the 15+ yrs of playing WoW, Norton has never blocked it. However, since I’ve seen that suggested to others with recent Bnet issues, I went ahead & spent (wasted) the past hour or so completely uninstalling Bnet (all the steps above that Irontorne listed), then Norton, then reinstalling Bnet & seeing if it made any difference at all… None. So no, confirmed it’s got nothing at all to do with antivirus & that possiblity can be taken off the table. And for the record, no, Windows Defender doesn’t automatically kick in if 3rd party antivirus is uninstalled (especially if it’s been previously & intentionally disabled)… confirmed that also.

I believe it’s specifically a Bnet issue, and I know the update 5/4/21 is the clue, as that’s when the problem started… that’s why I indicated it. Another clue may be that when I have clicked ‘Install’ just to see if it’d recognize it’s already installed, it shows the install path aiming at the ‘World of Warcraft Public Test’ folder, which isn’t even the ‘Default Install Directory’ location. Given that, it’s something for Blizz to look at, specifically what they changed in that update that could be causing the issue (and I’m not the only one with this problem). If somehow that update changed where Bnet is looking for the game files, or the specific file name it’s looking for, but didn’t change the target file name/location, then it’s like they blinded it.

Edit: it’s actually been since around the last week of April that Bnet hasn’t recognized the games are installed

If you haven’t already - I would open a ticket:

Contact Support - Blizzard Support (battle.net)

1 Like

Opened ticket a couple hours ago, but things just took an infuriating turn (ticket updated). I installed/updated TBCC for the pre-patch stuff after reinstalling Bnet (again), but now WoW retail won’t load at all. Every time I try a popup indicates an update is available & to launch the Bnet app. Click ok, it automatically launches Bnet & goes to TBCC, but ‘retail’ still says “Install”. I uninstalled TBCC to try & get back to being able to lauch WoW from the game folder, but no go.

From another post in the forums, seems like others are having issues with games not launching after doing the TBCC update…