Auction House Issues

I was told to post here by Support agent Laenowatar about my missing items and gold on 1.31.2020, this is the 4th time reaching out about this issue, i had posted over 5,000,000g worth of items between 1.12.20 and 1.26.20. There was a mailbox bug, i sold 700k worth of items on Vexent-Tichondrious and 2.6m on Sovathida-Tichondrious i only every received 500k of my gold.

The Support agents have not helped me what so ever about this issue, i have tweeted to blizz cs. i have made countless posts on Reddit and contacted blizz support through the ticket system.

When i spoke to them they said they could track my items, when i listed my items from my CSV, they no longer wanted to help me because it was " Too Much Work".

I’ve spent days farming. invested over 15 years into this game, from the time i was a child to now being 25. This wasnt my screw up, this wasn’t me deleting a mail or abusing a system. This was Blizzard’s bug.

I would like to have my issue sorted.

1 Like

Is the AH still eating things? Because I remember putting some ore up and it hasn’t sold or been returned so I checked and I have zero listed auctions.

1 Like

Yes it is. Just came here to report that I had a Microbot battle pet up that is no longer listed in my auctions, and I have not received the gold, nor the pet back in the mail.

If it helps the software people at Blizzard, my auction was not strict buyout. I put the option for a lower starting bid. There was a lower bid on the item, and then when I just logged in to collect mail it was neither in my mailbox, nor was there any gold for it.


Still unable to receive any mail whatsoever (including non-auctions) on my alt that I bought 170k worth of tidespray on and never received.

I’m honestly not very optimistic that any of that gold is coming back to me.

Since 8.3 and the new Auction House, I have been unable to place any bids in the Black Market Auction House. The items up for auction display, but there’s no way to place any bid.

1 Like

I made a separate thread for this, but I’m adding it here because it’s AH related:

When I’m going to post items sometimes it gives me this message and it won’t post the items.

It happens with and without addons enabled.

It happens more often when I post things with a different time frame than the last post. For example, if I posted the first stack at 24h (because for some reason the AH is defaulting to 24 even though I preffer to post most things at 12h), then the next stack I post at 12h will likely have the “Internal AH error.”

Reloading can sometimes fix it. Logging out and back in can sometimes fix it. But, neither fixes is consistently. Sometime I just have to wait or close the game entirely, like right now.

This is very annoying.

1 Like

same issue. The other day I saw a pet I’ve been looking for and I just could not bid on it.

49,000 day AH items, item that wont even POST to the AH i thought you wanted to make it better not worst.

1 Like

I’m still not getting notifications of sales for anything that sells in a stack. Transmogs seem to notify me, but I get no sales notifications for anything stackable.

Gotta ask again is favorite thing still broken? I used it and items remind there for several hours, but after I woke up they were gone again… not sure if this is still a problem or maybe some of my addons (none of them about AH)

1 Like

Don’t worry peeps at the end of the 30days it wont be an issue. That’s the secret fix. Just don’t tell anyone I told you!

1 Like

yeah, that’s what I’m ultimately worried about. I just don’t trust them when they say none of it will be lost.

1 Like

It is unable to filter for unobtained pets in the new auction house. After 8.3 i am no longer able to filter for only unobtained pets. Even if i tick the “Uncollected only” or “Usable Only” I still get up pets that I already own.


When collecting auctions from the mail box, the character wealth statistics aren’t properly being incremented.

I swear there’s still some ore I never got the gold for. >_>

Still having this issue in April 2020. Takes me so long to post things because I click post auction and it doesn’t post the item :confused: Only small fix I have found is by changing any value it allows me to post right away, so usually I’ll just under cut by 1 silver instead of posting at same price so that it’ll actually post the item for me.


The auction house has been majorly broken since it was re-designed. I have complained about this before, and even opened a ticket but the ticket was removed, and my comments ignored. My major gripe is that since the re-invent, I have been unable to bid on anything in the Black Market auction houses! There is no bid button or anything that allows me to enter a bid. it doesn’t matter which Black Market auction house I’m at, and it’s both with and without any add-ons. I simply cannot place a bid!! I wish they would bring back the old auction house!! But, if they won’t, then I wish Blizzard would respond to this and not simply make my tickets vanish!!

1 Like

still an issue in May, Blizzard address this finally pleasE???

1 Like

I put an item in and click post and it literally won’t post. 10/10 good auction house.

I have put in bug reports in game the last several months. I list a lot daily and it should not take hours to list 20 minutes worth of stuff. PLEASE FIX, it is driving me crazy!