"api-ms-win-core-com-l1-1-0.dll is missing" error during Waking Shore quests

I actually double checked, that one isn’t part of the re-distributable DLLs that MS provides as part of the Windows SDK that you’re legally allowed to distribute. So this smells like an anti-virus problem.

I’m very curious what they are using it for because in the code (a personal project) I have this is what I’m importing from it:

 api-ms-win-core-com-l1-1-0.dll
             140352628 Import Address Table
             1404F32D8 Import Name Table
                     0 time date stamp
                     0 Index of first forwarder reference

                           7 CoCreateFreeThreadedMarshaler

But that would be an unusual thing to have in a game. Honestly they could just link directly to ole32 which is the documented export for that and similar.

I was getting this same error and wasn’t able to launch the beta after this weeks last build. Retail and PTR both worked fine however. I fixed it by uninstalling the beta client and reinstalling it. If you haven’t tried that, give it a shot, it worked for me.

1 Like

Thanks for this, reinstalling worked for me (for beta, haven’t installed or tried PTR so can’t comment there"

Went and tried reinstalling just now, and the game seemed to launch and run fine until I tried switching the Graphics API to DirectX 11 (it defaults to 12, which historically has been horrible).

Attempting to switch to DirectX 11 caused an api missing error followed by a crash. DirectX 11 Legacy ran okay for a while at low frame rates, but eventually gave a crash.

The game appears somewhat stable when running with DirectX 12. Performance is abnormally low compared to what I was getting with 11 in the previous build.

Api missing errors are not as common as last build, but they do still happen, and now seem to always precede an app crash.

In particular, using DX11, spending Dragonriding talents, and trying to open UI Edit Mode when the button is greyed out appear to be triggering them now. Quests that triggered them before do not appear to be doing so, but there were quite a few so it will take a while to check them all.

Note: 12 is now required for DF per the system requirements 11 may work as documented but it may also be crashy. So that appears to be no longer maintained well.

What GPU are you using and driver version? Because any “modernish” GPU should be fine. But this is the new minimum requirement:

DirectX® 12 capable 3 GB GPU
NVIDIA® GeForce® GTX 900 series
AMD™ GCN 4th gen
Intel® Iris® Xe Graphics

Note 2: GCN 4th gen refers to AMD RX 570 and above GPUs for the most part, while some of the 400 series may technically qualify they are likely not going to function well per shadowlands already putting them out of spec.

That could be the problem. If so, it’s a bummer, 'cause the DX12 backport is pretty sucky. Fingers crossed that next week’s build will fix the crashes as per the blue post and I can go back to DX11.

My GPU is an RTX 2060 6GB. Prior to this week’s build it handled the Dragonflight zones just fine. As an example, I was getting about 70-75 FPS in Wingrest Embassy. This week it struggles to even get 45 FPS in the same location on the same settings. Not every location is impacted as strongly, but overall FPS is still lower than last week. Since nothing else appears to have changed, I can only guess that it’s due to poor optimization of the DX12 backport/DX11 Legacy.

Are you on the game ready driver from NVidia directly? Because that GPU should perform significantly better with DX12. If you’re on the windows update driver that may explain a lot.

Still getting crashes when I try to switch to DX11 in the latest build. Same errors.

Yes, I’m running the latest game ready driver available from Nvidia’s website (473.81). It’s a security update driver so it may or may not actually be game ready.

Going to try rolling back to a previous version to see if that helps with frame rates.

How to do a quick fix on your Windows 10/11 pc.
(Not sure if command will work for older versions of Window, google it.)

Close any programs you may have running,
especially any blizzard games or the blizzard update agent.
(Must be connected to the internet to get the DISM built in command to work.)

Open CMD with administrator access:
(Click on Windows search bar, look for cmd when the list pops up,
right click on cmd.exe and hit “Open as administrator”.)

Type the following in the cmd window (then hit enter):

SFC /SCANNOW

Then type or run the following: (then hit enter)

DISM.exe /Online /Cleanup-image /Restorehealth

Then the following:

CHKDSK C: /F

When/If it says it cannot lock the volume,
press the Y key and restart the computer. (edited)

(This will ensure you have a complete image without errors on your pc of windows.)

Also allow Windows to do its updates if you are having trouble with that then it might be the cause of the issues, especially if Windows update is completely turned off.
(You do not have to upgrade to Windows 11 - that is optional so far.)

If you are having lots of trouble finding drivers manually for your PC,
you might have to use a 3rd party app to “fix” it.

I have been using this app for a while from iobit called “driver booster”.

The only caveat I have with it now is that they have started bundling vpn software with it so when you install it make sure you read every panel and say “no” to any extra software.

It normally finds a bunch of drivers without issues once in a while it does mess up but you can always revert back to the original drivers if you have trouble.

That is atrociously out of date for that card; latest driver is 517.48 and there are critical security fixes in between. Again running DX11 on that card should not be advised.

It’s dated August 2, 2022. It’s not that out of date.

As for DX11 being advised - I’ve been running DX11 games on this card since I got it, and Dragonflight build 45698 is the first thing that has ever given me issues. :dracthyr_shrug: Shadowlands runs perfectly fine in DX11, as did prior Dragonflight Beta builds, so I’m disinclined to believe it’s the graphics API alone that’s the issue. More likely Blizzard just broke something.

As noted above, the DX12 backport has never been an improvement over DX11, even compared to Legacy. From prior experience, DX12 is the least trustworthy option.

Given that performance was fine prior to build 45698, and no other variables changed, all the evidence points to Blizzard screwing something up.

1 Like

So please note that DF the minimum requirements switched to DX12, that’s not to say DX11 won’t work it’s just to say that it won’t be given the same attention it has in the past. The issue with DX11 in general is that it requires a lot more graphics driver support than DX12. Thus it’s on the GPU manufacturer to optimize how the game runs on their card. This is why Intel preforms like absolute garbage in most DX11 titles on their new GPUs.

About that… an experiment worth trying: Go into to the NVidia control panel and set up custom settings for the DF WoWT.exe and WoW.exe Make sure the power options is set to “Maximal performance” instead of “Normal”. My hunch is that because you’re on Win 7 it’s not properly detecting the game is running and swapping to high power mode if you use DX12. I’ve recently done this and it stabilized some framerates even on Win 11.

My guess is more that blizz changed things to better support the DX12 pipeline and the Nvidia driver is applying incorrect optimizations for DX11 mode along with the power thing.

I still recommend upgrading to windows 10 and being on supported software. Windows 7 has not had support from MS for two years now and the GPU drivers you’re running on are actually fairly out of date and appear to be getting potentially security updates only. So you won’t get any DF specific optimizations NVidia puts out. But at the end of the day it’s your computer and you are free to take what risks you desire.

Still getting api-ms-win-core-com-l1-1-0.dll is missing .
But thats better then hitting play then nothing .

This helped a bit with the low FPS. For some reason the default is set to energy efficiency. Setting it to maximum performance resulted in ~15-20% better framerates in some places. Still not as high or smooth as they should be, but the game is more playable.

Which API? DX12 or DX11 (please tell me you’re not using DX11 legacy…)

DX11 still crashes the game when I try to enable it.

DX12 and DX11 Legacy both went up by 15-20% after enabling high performance mode. There’s no difference in FPS between the two; they’re both lower than they should be for my hardware.

I know you’re firm on staying on Win 7 but the latest Nvidia driver released today 522.25 has significant improvements for DX12 performance on almost all supported GPUs unfortunately it does require Win10+.

My friend its probably time to just upgrade your computer (for free) to windows 10 and use DX12 there is no point not upgrading/updating other then having to know an extreme amount of knowledge about windows systems and executables and being able to fix basically the entire system every time something updates. Your better off if you want something like this using a linux supported OS.

Your graphics card is actually pretty good and your performance for no hardship would increase significantly.

Having the same error on retail now that it’s prepatch.
Given the choice between “upgrading” Windows 7, or not playing WoW-- I think I might just not play WoW.

7 Likes