Anyone unable to transmog Tiriosh, nightmare of ages?(legendary cata daggers)

Apply button does NOT work with the legendary cata daggers, keeps playing the sound like it applies but does not. If I change to a normal other dagger it applies fine.

Edit: credit to Saimeren for the solution:

Rogues, when selecting your legendary, right click the picture in the menu and choose the other option. You can only mog the left hand into the left hand and the right hand into the right hand. When you right click the picture, the drop down menu shows up and you have to select the main hand separately.


He talks about the solution to the rogue daggers.

1 Like

solution dont work

Thank you, solution works perfectly!

Open the transmog page, select your weapon, and on the right where all your appearance options are, go find the legendary dagger.

Once you select the dagger it should come up with one of the two names.

Tiriosh, Nightmare of Ages is the offhand slot weapon. This can only be transmogged to your off-hand weapon.

If you right click it, a drop down box comes up and you can select the main-hand version of the appearance.

Golad, Twilight of Aspects.

This can only be transmogged to your main hand. You have to do them separately.

You can’t use the same appearance for both. You have to choose one than the other.


turned out mine was an addon being a pain, the solution works.

Just amplifying this. It works the same way the Druid Artifact appearances work. You right-click on it.


This still doesn’t work for me. I’ve already tried the method where you right click the correct hand weapon to transmog but still nothing. It’s either bugged or simply poor user interface.

It might help if the mh/oh designation was simply removed from the original Fangs. Having to match them in the right click menu isn’t exactly intuitive, and it will be extra wonky when switching between sub or mut and outlaw and making sure transmogged daggers are equipped in the right slots to not break it.

Someone else said it was a addon problem that interfered.

Okay I finally got it working. The default legendary dagger in the transmog list is actually the OH one. I assumed it was MH and had the two in reverse. Definitely could’ve been designated better/more clearly.

1 Like

As I said (on my durid), it’s not very intuitive lol.

I really only knew which was which since the originals live in my bag to use the dragon wings.

Hell, my Rogue can’t mog to them at all, daggers don’t show up in the options list. So they are obviously SPEC specific

Worked perfect, you da man

Worked perfect, you da man