Aiding the Accord: The Hunt is On

partiicipated (solo) from the start to finish of a hunt, received the reward but did not receive credit. This seems to be an ongoing theme for many of the limited quest events. So far I’ve not had credit from a workd boss (had to kill 3 times) , The Cooking chaos thing.
Reporting these in game in hopes of seeing it corrected isn’t much help with the 2 week wait time for a response when reporting.


not to mention the lost loot and rep


People on wowhead are saying you have to speak to the centaur at the end (Scout Tomul?). The Hunt may complete after the first person talks to that NPC but for credit on Aiding the Accord, you have to as well.

I haven’t tried myself, yet…as I haven’t been able to find the NPC today

Has anyone got a fix for this crap yet? I’ve now done four hunts. Three have been from start to finish and no credit

I also am not able to get credit. They not reply about this issue yet?

Apparently this fix went in Jan 6


  • Valdrakken
    • Deployed additional fixes for “Aiding the Accord: The Hunt is On" not always granting quest credit when completing a Grand Hunt.

Well their additional fix didn’t additionally fix anything. -sigh-

Losing out on some rep because of this.

As a note on 1/9/2023 this is still broken despite the it supposedly being hotfixed on the 6th.

1 Like

Still broken (sigh)

Still broken, did 2 hunts and received no credit towards weekly quest

Same. No credit as of 2023-01-31.

[Aiding the Accord: The Hunt is On]
No Credit

can confirm below works
People on wowhead are saying you have to speak to the centaur at the end (Scout Tomul?)

1 Like

Still broken as of today, talking to the NPC at the end does not work either.

Edit: after my 4th hunter it worked properly, I did not have to talk to the NPC

1 Like