[9.0 ptr] [linux] error 138 & 109

–This is on Linux, using Wine 5.8 (Staging) and DXVK 1.7. I know Linux/WINE are not officially supported, but there’s been occasional help from blues before for Linux issues so here I am.–

Upon starting the game, it loads the main menu fine, but after ~10s I get this error:

ACCESS_VIOLATION : error 138: ERROR #138 (0x8510008a) Fatal exception!
The instruction at “0x0000000000000000” referenced memory at “0x0000000000000000”.
The memory could not be “executed”.

For testing purposes, I changed the winecfg from Windows 7 to Windows 10, and the error changed to Error 109 the first time:

error 109: ERROR #109 (0x8510006d) A thread has become unresponsive.
Freeze Detected: thread 36 has been frozen for 20 seconds

However, the majority of the time on both Windows 7 and 10, it throws Error 138.

The retail and classic clients work perfectly fine.

3 Likes

I’m also getting this error on Linux when I try to launch the PTR. It launches a black screen, and I can hear the login music, but nothing happens and eventually I get the crash message. Running Pop OS 20.04 with Lutris. Not expecting a ton of help here since the game isn’t officially supported on Linux, hopefully it can be fixed with a Lutris/Wine/DXVK patch.

Same issue here on Manjaro using Lutris. Classic and 8.x use same runner, everything works fine. I get about ~10 seconds of screen before RIP

1 Like

I just made the switch to Linux and it didn’t cross my mind until now because the setup and play with Lutris was perfect. How are the WoW games during launch for Linux users? Do we have to wait for 3rd party patches and updates or is it typically ready to go out of the box?

I’ve found Wine Staging to be needed for the best dxvk support lately, but generally Classic and Retail have been running fine on both staging and out of the box. There only really seems to be an issue with the PTR at the moment.

I am using wine staging 5.10 and dxvk 1.7 with the same results as you. Retail has been playing fine and the ptr crashes every time. For what it worth a 5.4.48 kernel and nvidia-drivers 44.100. Had tried a later video driver but retail started crashing so went back to that version.

For awhile now all I have needed to play retail is a clean prefix for wine staging and winetricks to install dxvk.

edit: same results after deleting Cache, all addons, WTF

Try updating to 5.14 staging.

I did so and it is working now. Loading screens are abit slow and I get some random fps drops but it’s otherwise playable.

3 Likes

Thanks, this worked for me bro

I had previously tried 5.14 and retail would crash every time as soon as wow was launched. Found 5.10 was the latest that worked for me.

Just tried 5.14 again with the same thing of retail crashing and ptr crashing even faster than with 5.10. For the moment went back to the version that is working for me. Thanks for the hint a later version can work.

Question of the moment is what are you installing in the wine prefix? Using lutris or winetricks manually? All I have been doing is in a new prefix ‘winetricks dxvk’ and going with that.

Same thing here. Good thing i signed up for PTR and went to test it, or i would have found this nightmare on prepatch day.

Supposedly 5.14 staging fixes the error #138. Lutris does not provide it due to some issues on 5.7+ versions with ntdll. I compiled 5.14 staging myself and created a new game via the lutris website, changing the wine version before launching it after installation. Bnet opens up fine but the wow window shows nothing (just a “snapshot” of whatever was on the screen when it launched), and no sound. This is true for ptr and retail. At the moment i am back with an older version so i can play retail.

Supposedly you have to compile 5.14 staging with mingw, haven’t figured out yet how to do so. Otherwise it would be hoping that everybody gets their mess fixed and lutris ships an updated wine runner befofe prepatch release. Also, some people had this same behaviour with beta.

Hey everyone,

I just want to throw in my two cents here by saying I had this issue too… I fixed the problem by installing winehq staging. Go to the winehq site, and add the PPA if you are on an ubuntu machine… then install winehq-staging. Finally, in Lutris, right click wow and click configure… and select the newly installed winehq-staging version from the runner tab.

Make sure you have restarted lutris before you do that part. Works for me.

1 Like

That worked for me! One thing that gave me trouble: I didn’t have “World of Warcraft” installed in Lutris, instead I had the Battle.Net launcher installed. When I tried to change the runner to winehq-staging for the Battle.Net launcher, it still wouldn’t launch the PTR. So instead I added a new Lutris game and pointed it to the World of Warcraft exe, then set the runner for that to winehq-staging. Doing that got the PTR working for me.

2 Likes

i can run ptr on linux.
Ubuntu 20.04, winehq-staging 5.15 (from winehq-org ppa), dxvk (from git).
In Config.wtf the variable gxApi must be D3D11 or D3D11_LEGACY. D3D12 won’t work.
I don’t use Lutris.

Edit:
No change on PTR 35598. On D3D12 i’ve got error message in console.

  • D:\BuildServer\WoW\2\work\shared-checkout\branches\wow-patch-9_0_1-branch\Engine\Source\Gx\src\GxApi.cpp(1246) : error 139: ERROR #139 (0x8512008b) Informational assertion failure!

In Logs/gx.log multible times.

  • 8/19 21:24:51.782 Device context was lost. Attempting recovery. Occurrence: 1
2 Likes

Finally got back to this. On gentoo mingw is disabled when compiling wine staging. The reason given is a bug that was closed May last year.

Removed the restriction based on a closed bug and installed mingw. After recompiling wine staging 5.15 the ptr now runs and for the 1st time retail has worked for me with anything higher than 5.10.

A clean prefix with winetricks used to install dxvk. As I have never used lutris what does it give you over wine-staging + dxvk?

1 Like

last year I could only play wow+d3d12 with significantly less fps under vxdk instead of dxvk. currently i can’t play with vxdk at all on retail client.

on ptr i must play under d3d11. for some textures vxdk produce gfx errors like adding rainbow colors to alpha channel.

  • https://imgur.com/gallery/eBf5kBq

But maybe it could also be due to my hardware (ATI Radeon RX 580X).

One thing I just discovered last night, I can’t launch the PTR with Mangohud (fps/performance monitor) turned on. Removing the mangohud command from my Lutris startup lets the PTR run again.

I also use Gentoo and I’m interested in this. Did you have to use crossdev or just installing mingw and setting any USE flags for wine? Or does wine automatically compile with mingw if it is already installed previously?

Lutris provides a cleaner management of all the overhead of running wine, such as setting the prefixes, automatically pulling latest dxvk, etc. I’ve had serious issues in the past when mixing different wine versions on the same wineprefix (computer would lock up), so lutris (when used correctly) takes care of that. Also lutris installers for games take care of setting up the prefix with every component needed, not just dxvk. Additionally, it has supports for different runners other than wine (such as steam or scummvm).

Case in point, i have two wow games configured in lutris (one for bfa and the other for SL). Both point to the same bnet binary, but have different prefixes and wine versions. This is so i dont botch my normal install on a raiding night :wink:

So finally got it running. It stutters like hell and it’s not due to wine, as i can run retail with the same wine version and it works fine. Also, setting the graphics details down to one does not make a difference, but at least it runs.

I doubt there’s anybody else using Gentoo here, but the way i did it was by installing mingw’s toolchain using crossdev, then editing the wine-staging ebuild to remove the --without-mingw line. After that i emerged wine and it detected the mingw compiler that crossdev installed. Everything worked fine after that.

If you are using a binary distro like Fedora or Ubuntu, make sure that the wine package that you install was compiled using mingw. It won’t work otherwise.

1 Like

What I experienced were two
Things. I use mint ulyana.

You need winehq staging 15.
If you’re using hybrid mode (pop or mint, maybe others), switch to dedicated mode. The version of wine fixed the error but not the stuttering, apparently the video card was not properly switching. :man_shrugging:

Btw love y’all. Linux community is the best :heart:

3 Likes

Works fine in Linux using wine staging 5.15 however things can vary as everyone setup can very in Linux. I use arch linux with linux tkg pds lts 5.4 kernel with fsync enabled works quiet well with 5.15 staging.

Newest proton and custom proton no go for me with WoW had to try lol.