WC3 60FPS cap question

Hello, i would like to ask, is it possible to remove 60fps cap in wc3??? If yes, how?

Do you run your client in native fullscreen mode?
If not, add “-nativefullscr” to Warcraft III executable - that should remove the cap

Hi, in this answer I am assuming a Windows PC with 60hz screen refresh rate. I have no idea about Mac

The 60 FPS cap is caused by Vertical Sync. Vertical Sync is on, because Warcaft 3 uses “Fullscreen Windowed Mode” by default. By running Warcraft 3 in native fullscreen mode, the FPS cap will be removed. You won’t find such an option in the ingame settings menu. Instead, you have to run Warcraft 3 through a special shortcut.

  1. Right click on a shortcut pointing to Warcraft III.exe (eg the shortcut on your desktop)
  2. Append -nativefullscr to the shortcut path. It will now look like this:

And here is some guy showing how to do this on youtube.
That’s what works for me, I hope it works for you too!


im using 1440p/144hz monitor. i just type -nativefullscr and max i hit now is 200fps. i guess this is new cap? im sure my 1080ti’s can push more then that -.- feels good to finally play this above 60fps.

edit: yes i use win10, vsync is off on global for me.

Worth noting that Warcraft III was not really designed for anything above 60 FPS. It is possible that mechanics like unit movement or rotation might not be interpolated at high frame rates and hence they would bring you little benefit over 60 FPS. It might be worth performing a video capture test to make sure that no duplicate frames get drawn at those frame rates. Otherwise it is just needlessly taxing your video card and CPU.

Client-side actions would prossibly run at a different frame rate. Primarily moving the camera and selecting different units. The cursor is also a special case.

You might could raise it via regedit. It’s set to 200 in the registry.

Here’s the path: Computer\HKEY_CURRENT_USER\Software\Blizzard Entertainment\Warcraft III\Video

ty, now fps limit is at 400+ , damn smooth, just have to set GPUs for maximum performance mode on wc3. cause main one still downclocks to like 400mhz, since second one is doing ‘‘heavy’’ lifting with physics

1 Like

I assume you mean a background application you are running is using it for physics? Since Warcraft III was made long before compute shaders existed and hence only uses GPUs for graphic acceleration, even using the fixed function pipelines of pre programmable shader days.

1 Like