Warcraft III Classic Not Connecting to Battle.net


#1

To whom it may concern,

At the suggestion of Blizzard Support, I’m posting to this forum to report on an issue with running Warcraft III Classic: after downloading the Mac launcher and installing the game, clicking the “Launch” button does not give me the option to verify my Warcraft III: Reforged purchase and link to my account. Instead, I’m immediately taken to the “Owner of this game/CD key screen.”

In regards to troubleshooting with Blizzard Support:
-I downloaded the classic Warcraft III installer by going to the download games tab on my blizzard account.
-I also deleted the installer/game and re-downloaded the installer/game after my purchase had been processed. The CD key screen still immediately popped up.

Please, let me know if there are any solutions to this that will allow the game to be run.


#2

i’m having the same problem on my mac, any solution from blizzard?


#3

I am having the exact same problem with the Mac launcher, pls, can someone help?


#4

I am also having this problem. I downloaded both the “Public test setup” and the “normal” warcraft 3 launcher, installed and tried them each with the same result asking for a CD key. I thought it was because I didnt buy the Collectors Edition of Reforged, so I upgraded my purchase. Tried the installers again and still asks for CD key, not seeing I purchased Reforged.


#5

only solution is to go to your account page and get the cd-keys from there.


#6

Where would it be on my account page after purchasing reforged? I was under the impression that they had gotten away from the CD key system. Support had suggested that I mention this issue on the forums to bring it to the attention of the developers