Very low fps in game W3 classic mode

Hello friends, i have the issue with reforged. I play on classical graphics, however my fps drops to 15/20 and it is unplayable. I also have the latest drivers. My PC is with 16GB RAM and 3GB NVidia Geforce 555M Graphics. I tried everything - reinstalling W3, even reinstalled windows, but nothing helped.

Is this playing the campaign/melee? Or when playing custom maps? Some custom maps just will perform badly, especially on mobile hardware as not all custom map authors are good at or focus on optimization.

Since you say your frame rate drops, does this mean that it starts out fine? If so then this could be a sign of thermal throttling. Look at the CPU and GPU temperatures. If they are very high and there is a noticeable reduction in clock speed then this is a sign of thermal throttling. You can also use tools like CPUz and GPUz to help detect this.

Make sure you play when the device is plugged in so that it can operate with optimal power limits. Also make sure that when playing the power management settings are set to maximum performance or balanced and not to energy saving or battery life as those will limit clock speed.

Some laptops may enter a safe “slow” mode if their battery is detected as degraded. In this mode both CPU and GPU are locked to a minimum processing speed. I only know of Apple laptops having this mechanism but it could explain low clock frequencies if that is an issue.

yes i have laptop. it is dell, old model 2010. I have set the power management options to high performance , still i make one game with normal fps and then it drops again to 10 fps… i tried everything but nothing helps ! Does anyone have the same problem ? is this from warcraft 3 or is it my system ?