Two Issues Upon Update: Unable to Join/Access Custom games and Cannot host downloaded Custom Maps

I have two MAJOR issues, one of which I tried filing with Blizzard but I couldn’t get round their system. I find it super confusing the way they have put it as I needed to upload a file and I didn’t know what they we going on about.

  1. Here is what I tried filing to Blizzard:

'I am a long term player of the original version Warcraft 3 (Classic). I recently downloaded the recent update to the game believing it was the only way to continue playing the game. This update included new changes to streamline the game with reforged. As a result, I encountered an issue with the custom game system despite having ‘classic’ mode graphics on. I do not wish for reforged graphics or content, I just want to play custom games as I have always been playing.

Upon clicking on ANY custom game, my game proceeds to redownload the map before telling me with a yellow triangle and exclamation mark that I cannot play the game and enter the lobby. I am not sure if other people have had this issue but I’m certain they have experienced similar things such as lag. This was not an issue in the previous versions when reforged did not exist.

A second issue I noticed was that the new chat feature at the bottom (which was not there before) switches to ‘[Lobby]’ once this happens to me, meaning i’m unable to chat to other people to get help. It looks like no one knows how to help me on the main game. When I get this error at the bottom screen, I have no idea how to switch back to the original lobby or whatever it was I was in. This ‘[Lobby]’ i’m talking to may be the lobby of the game I was supposed to have joined…but obviously I am not in it.

Please help me. I just want to play WC3 as I have been for eight years not download a paid version just to fix it. If it were possible i’d advise changing the classic version back as it is just too confusing for people like me.

A written guide on how the new system works would benefit me greatly.’

It seems that reforged and classic WC3 are one in the same now. I cannot comprehend this change as it means now more effort when simply going for the original WC3. I would prefer it if the classic version stayed as it was. I cannot join games, it wont let me and when I scream for help in the lobbies, no one answers me.

Now onto the second error.

  1. Upon trying to create a custom game/game of my own, I am prompted to do the usual, pick a Melee map or a downloaded custom map. I click on the downloads folder. The game FREEZES and then crashes and I have to submit an error report. The game doesn’t want me to host games of my own. Surely this has not happened with everyone as I saw custom games such as Orc Gladiators and Legion TD and Green Circle TD being hosted, which require access by other players to this folder.

A simple answer to both these problems would help me greatly. What’s more, if you can try to not make me tamper with my files, I think that would be good. I don’t think it’s a problem with my own files. I think it’s a problem with the game itself you’ve updated. Any help regardless would be appreciated. These errors do stop me from enjoying a game I’ve been playing for more than 8 years now. This is one of the first real major changes. I’m posting this here because when I click on the WCIII support button, it simply brings me to Reforged as if they are the same thing.


1 Like

Blizzard say something please.


I am aware that part of this issue has been already cleared up, but you should know that some people WERE able to host games upon download and more were able to join games. Something is wrong. It’s not letting CERTAIN people…it’s not everyone…but I feel a majority or just less than half.

still no reply wow… just WOW…

1 Like

Still no response from Blizzard? This issue is different from prior ones despite having some of the same symptons. Considering how quickly you got to other people (within 10 minutes-2 hours) I was initially very positive and hopeful. This issue will not go away any time soon. This is permanent…and there’s no way of me or other people enjoying ourselves here. This is literally the only game I’ve been playing for the last year at least. I appear not to be the only one but the instructions you HAVE provided do not work for some people like me.