Rise of the Blood Elves campaign bugs

Level 1 of the blood elf TFT campaign is bugged in various ways: the amount of lumber you are supposed to acquire to repair the first observatory is not enough, even with the first and second caches. This was not the case previously. Also, the game CTDs when building a farm with the first peasant you have, and also occasionally when selecting the town hall. This has happened repeatedly when i tested it. Level 2 of the same campaign is bugged as various units from the purple/orange undead factions spawn in your outlying bases with no AI, so they just sit there and get killed by the towers, and they are not supposed to be there at all. Also, the spaced font bugs out the text for the tiny castle and the name of the green dread lord that assaults your base, they are both blank and some of the font is shoved extremely far to the right, floating in mid air.

I was not able to reproduce these issues. Were playing in HD? What difficulty?

The crash makes me think your install may be bad as that would be art related. Have you tried repairing your install?

Yes I was playing in HD, and on normal mode. I also tried repairing my install, nothing wrong with it. Also it seems you found me here from my thread on hive so that’s good.

I’ve tested this on Normal and Hard now. I also asked someone else to test it and they were unable to reproduce the issues.

Could you explain how you were able to reproduce them?

Basically what I did was use the cheat motherland to warp to the blood elf levels from the campaign, so I could experience some of the new changes. When I was playing, I noticed that the first observatory wasn’t able to be fully repaired despite me finding the first two caches (which IIRC should be enough to fully repair it). Then, I just played the mission normally, I got my units into the boat, including the first peasant I got, and went to the island, killed the mobs, and set up my structures from the tiny items (the town hall had no text and was blank, something I suspect is due to the new font change). The first time I was just building my first farm and clearing the creeps on the island, and as I was selecting my town hall to build my first extra peasant, it crashed. Naturally I reloaded the saved checkpoint and it happened again. I tried it again and this time it didn’t seem to crash from the peasant, but just from me building the farm. I tried it again and it happened again, so I just went to the next level via the campaign menu. That’s when I noticed a bunch of undead units spawning in my outlying bases that had no ai, theyt just stood there getting pelted by the towers. Eventually, when the dread lord attacks your base, his name was completely missing on hover, and his level (7) was pushed extremely far to the right side of the screen. Again I suspect it’s due to the font changes.

I followed your path exactly and the only issue I ran into was the missing text. This is not a font issue, the fields are actually blank. I will report these.

As for the second map the Dreadlord attacks within the first minute with the rest of the forces. At this point all I can say is that your install or save file is somehow bugged.


That’s odd. I’ll try to replay the missions from the beginning from the menu and see if there’s any difference.
EDIT: It just happened again. Was selecting town hall to train 3rd peasant. Clicked on the gold mine for a rally, crash.