PTR still does not work on Mac

Same as previous build, PTR client opens, you get the screen with the lion (or just a black screen, in some cases,) and nothing happens. Running Mac OS Big Sur.


PTR is usually windows only, its odd that you can even see a build to me

1 Like

Blizzard has never excluded Mac from PTR/Betas for games that supported Mac. I was able to played OG WC3 PTRs, and the Reforged Beta, but this PTR build will launch the game and then just stop at the main screen.

Similar issue here. Game starts on regular client, however PTR 1.33 just opens up to a black screen and then nothing, you have to force quit it.

Same here. How do you dare to release a build that does not work?

you could try to open a support ticket, maybe support can help you.

Bumping this again, does not work on the new build (18897) either.

Same here for me. Did they even test the PTR on Mac?

Issue persists on the new PTR build, 18931.

It’s not an issue, it’s by design

Blizzard clearly haven’t tested the PTR on Mac, as the issue still persists as of build 18931.

Hey to clarify PTR for War3 worked on Mac unintentionally for the most part - we only actively supported Windows. They may fix this but it’s not going to be a priority.



Still not working, as of build

Yes, he was on the original reforged team.

I got to the door screen, but I couldn’t click the “Play Offline” button since it was greyed out.

It wasn’t for me, looks like this was fixed on a recent update. Nice!

1 Like