Problem with Warcraft 3 resolution and -nativefullscr


#1

I added -nativefullscr for warcraft3 and I have a rather annoying problem.
My optimum resolution is 1280x1024 and I can’t use it if I have -nativefullscr
It gave me 1024x768x16 when I added -nativefullscr and if I try to change it to 1280x1024x32 or 1280x1024x16 my monitor will go black and a message will appear ‘‘Not in optimum mode 1280x1024x60’’
Any idea how I would go on to fix it. I’d rather use -window but seeing how it’s still not working properly…


#2

What video card do you have? Some cards have an interface that allows you to make specific changes to their games. Nvidia does, at least, though I haven’t checked WC3 to see if those options are available at present.

Could be worth a look, at least.

Also, it may be possible to make changes in the INI file to get the results you are looking for? I know a lot of stuff changed when they merged the executables, perhaps now it would be possible to do it there.


#3

I do have Nvidia GeForce GT 630 and tried to change it from there but same result, opening warcraft3 and showing ‘‘not optimum resolution’’ For a time it was stuck like that, not sure how it reverted to 1024x768x16 even after I undid the settings via Geforce Experience
I have no idea how I would go about making changes in INI file


#4

I’m not 100% sure either, but I know it is possible to force resolutions in certain games with it. There may be an online guide to it, or maybe not yet. If you don’t know how the INI settings work it’s probably not a good idea to mess around with them, it’s just a thought I had.

In the past (I think it was with Morrowind that I did it?) it was done by adding a line in the graphics section along the lines of “forceresolution 1280x1024x32” or something like that. But don’t just toss stuff like that in unless a guide tells you to. Damn, I wish I remembered more about that.

I think it is possible. But it may just not have been document how to do it yet.


#5

Welp thank you, I’ll keep looking and maybe someone here got an answer :smiley:


#6

Sorry I couldn’t be more help! I hope you get the problem fixed. (By the way, if you ask on other forums it could help to include system specs, GPU and windows version specifically, as those two things can have a major impact on such things)


#7

Welp will do that

GeForce GT 630
Intel® Core™ i5-3470 CPU @3.20GHz
Windows 7 Professional and 64 bit operating system

Now it won’t work in 1024x768x16, it directly goes in ‘‘not optimum mode’’ on both 1.30.3 and 1.28.5