Prince Arthas in Undead Campaign can't be seen

Can’t view Prince Arthas in the Undead campaign. Just see a transparent circle and can’t select him too unless I click his icon on top left corner.

I got invisible buildings in some undead mission, restart did help.

Can you guys send a replay or a screen shot? I can’t reproduce this myself. Were you doing anything weird before this? Potentially using any cheats?

Did you guys have TFT/RoC Installed/Campaign Saved Data before playing the Reforged Campaign?

The day the game came out I had a bug on the second level of the Human Campaign where only the Town Hall’s ground texture appeared, and I couldn’t select it. Restarting the level and the game didn’t help. I used the repair game files option in the launcher and then reloaded and that fixed it. The repair tool said it couldn’t find any files that needed repaired, so I almost think it might have had something to do with the 3D model being cached incorrectly or something? And the repair reset the file? I don’t know anything about game development so that might not be how it works, but I thought I’d mention since this seems to be a similar issue.

1 Like

Torelef, there’s a bug that anything can become invisible, unselectable and if it’s enemy, it’s only attack-able by a-move.

Happened to me in the campaign too.

No cheats and doing nothing weird.

1 Like

Did it ever resolve itself Evilif, similar to what Cheatoz put in their post:

Curious if that also fixes it for you, if its still happening that is.

I just beat the map like that. Didn’t try to fix it.
It’s pretty rare to happen, seen it only twice.

This is still happening! I can’t see Arthas after restarting multiple times. I have used cheats in some campaigns but not this one.
Also, didn’t have TFT/ROC Installed/Campaign Saved Data before playing the Reforged Campaign.

Where is your Warcraft III documents folder located ? The standard location would be : C:\Users\XXXXXX\Documents\Warcraft III

How can I send you a screenshot on this forum? Tried to attach but couldn’t so. I sent a screenshot to your support team! Issue ID: #71244341

If you want to email screenshots that would probably be better!

It is on my iMac under Applications