MOUSE LAGS ALWAYS! nothing helps :(

Dear blizzard team,

please tell me why i got mouse input lags when i play on my computer with my gaming mouse…

it makes it impossible to play, the only way to play it, is on my laptop with a really old and cheap laptop mouse. WHY? please help!!
i tried all the tips and tricks in the internet with nativefullscr, opengl… nothing seems to work, please fix this

deckart kain

you need to overclock ur mouse, signal is too weak, maybe mod it too, with thicker wire.

bump for the same issue. you are running on windows?

yea windows, but man the mouse works on all the new games today, its just with wc3

Is it input lag? Or is it display lag? On one side Warcraft III could be taking a long time to receive or process user input events causing it to feel extremely unresponsive. On the other hand if Warcraft III somehow manages to get too many frames sequentially buffered it can take significant time before results of user input get displayed back to the user.

Does it only effect the mouse or does it effect both mouse and keyboard? Have you tired lowering the poll rate of your computer mouse (some gaming ones have absolutely insane poll rates which not all applications cope with well). When in windowed mode and the problem is present, how do other windowed applications respond? Are you using dynamic framerate technology like freesync or Nsync? Have you tried disabling all overlays?

effects only mouse, and all other windowed applications respond normally. i havent tried reducing poll rate. i dont use freesync or nysync. hmm. i will try to reduce the polling rate, thanks!

What works for a lot of people is the -nativefullscr flag on the shortcut. You add it after the “Target” when you rightclick -> properties your icon.

1 Like

Play on native fullscreen, disable any kind of vsync, remove fps cap, disable framebuffer. You will have no delays.

This was in the patch notes for 1.30
Mouse Lag

  1. Run regedit
  2. HKEY_CURRENT_USER -> Software -> Blizzard entertainment -> warcraft iii -> Video -> Right-click -> New DWORD 32 bit value
  3. Value name -> oscursor
  4. Set to 1

It worked for me. Hope it helps you also.

1 Like