[Main Thread] 1.33 game will no longer launch on mac

Hey Jambrix, the issue is still not resolved. The icon was on screen for a little bit longer, but then closed as per the other comments.

still having same issue :frowning:

still not working

same issue :frowning:

still not working, after restarting and such

Still not working using 2015 Macbook pro High Sierra 10.13.6 Intel i5, Intel Iris Graphics 6000

still having the same issue after restarting launcher and MacBook.

Still doesn’t work for me, Monterey 12.5.1, Wc3 just hangs then doesn’t respond

Also for me, still not working

Still is not working for me either. Mac OS 10.14.2, MacBook Pro (Retina, 15-inch, Mid 2015)
Processor - 2.8 GHz Intel Core i7, RAM - 16 GB 1600 MHz DDR3, Graphics - Intel Iris Pro 1536 MB

1 Like

Same Issues, still not working on Mac. Really frustrating after all this process.

1 Like

Really, honest question here. Why is there not a simple way to roll back to a previous version when issues like this arise with new releases? I think that could be accomplished without too much fuss and it would go along way with current users.


check out actman on youtube

still not working at all after 3 days and no update from Blizzard? took me awhile to even refind this thread smh cant u just go back to original version since this new version obviously not working for a lot of people!!!

1 Like

I’m actually having the same problem but on a Windows machine. Installed the update last night, failed when I tried to play, uninstalled, reinstalled, no change.

Still not working (2015 macbook pro, running mojave)

Still not working for me too… Early 2015 Mojave 10.14.6

If it makes you guys feel better, I hear this update is pretty buggy across the board so even if we were playing things would be difficult.

I assume they have a long laundry list and we apple morons are pretty low on the priorities which I can’t say I blame them, we kinda asked for it.

1 Like

What is this, 2002??

What does “we kinda ask for it” even mean? I don’t remember asking for this?