[Main Thread] 1.33 game will no longer launch on mac

Just updated to 1.33, game won’t open now. Launcher starts up then immediately closes again. Tried many times, tried uninstalling and reinstalling, tried opening via a replay, no luck. Anyone else having this problem, or does 1.33 just not work on mac?


Having same issue on mac


Hello. I am having the same issue on my MacBook Pro. It begins to load as in the icon of war3 flashes in the docking tray. But then it disappears and nothing loads.


yep. same issue. glad I am not the only one

1 Like

same here …

1 Like

same here, tried re-installing, scan/repair and restarting.

1 Like

Hey all,

Thank you for the reports. We’re tracking this issue and will provide updates here.

Can everyone please share their Mac model and macOS version that is being used?
(Catalina 10.15, Big Sur 11, Monterey 12, etc)

Find out which macOS your Mac is using:


I’m also having the above mentioned issues.

MacBook Pro (13-inch, 2017)
macOS High Sierra, version 10.13.6

Hope it gets fixed soon!

MacBook Pro (15-inch, Mid 2012)
macOS High Sierra, version 10.13.6

2014 Macbook Pro, 10.13.6 High Sierra

2015 13” MacBook Pro running Mojave 10.14.6

same here!

High Sierra 10.13.6 having same issue game doesn’t start for me when i click play it just re-pops never opens… what can i do? I tryed reinstalling already.

wont work on 2019 Imac Mojave 10.14.6

Mac OS Monterey 12.1, MacBook air 2016, previously wasn’t working on mojave either

Any updates on the issues Jambrix? 2015 Macbook pro (13 inch retina ) using Mojave version 10.14.6.

Macbook Pro 2015 High Sierra 10.13.6, Intel i5, Intel Iris Graphics 6100 1536 MB. 8GB

Hey again,

The devs have been working on this and they believe the issue should be fixed at this point.

Please try restarting the Mac and Battle.net app to see if the game will launch properly now. Feel free to report back if it’s working or still encountering the issue. Thanks!

@jambrix Still encountering the same issue

Same issues