Just freeze


#23

I am ok with both shadows and occlusion off, and all other settings on medium or low.
If I have high on any effect I do see hangs, system is a new Alienware m17 and the nvidia drivers are all upto date


#24

turning off shadows helped for me too to play my first game without crashing within the first seconds.

first i thought the cause was my old customkeys.txt, as the game started crashing after activating custom keys. but now i was able to finish a match with no issues (including no shadows… :frowning: ) and with custom keys. (as “grid” is not working, btw. would be nice to fix that, too! :slight_smile: )


#25

Having the same issue here. Windows says I have updated drivers but I guess I will check the nvidia website as well


#26

Just confirming here that turning Occlusion Off and Shadows Off has completely resolved the crashing bug.

On a 5700 XT @ 4K60


#27

Also confirming, disabling shadows and occlusion resolved the freezing/crashing issues on my end as well.
AMD RX580 Powercolor Red Devil 8gb, i7-4770, 16GB DDR3 RAM, MSI Gaming 7 Z97, Samsung Evo 850 SSD,
Latest drivers on all devices.


(Torelef) #28

Thanks for all the confirmation guys! <3 hope you are all enjoying the game!

As for the minor hitches, you’re probably experiencing something off of our known issues list. “Loading assets for the first time in HD can cause performance drops.”


#29

same here, game completely freezes and I have to restart the game. My pc that I’m currently using is pretty low spec though, I’m going to try again on my gaming pc tonight.


#30

so turning off shadows and occlusion worked for me as well. Also improved frame rate drastically.


#31

Same here.


#32

Have this issue as well, turning off shadows and occlusion did work though. Unit models faces dont move at all though


#33

Same here, the moment i click on barracks the game locks up and crashes!


#34

Had the same issue until I turned off Shadow and Occlusion.


#35

Same!! I Clicked “Build Great Hall”, and freeze :frowning:


#36

Thanks.
I also turned off Shadow and Occlusion, so I didnt crash game.


#37

Hi guys,

I have the same issue with it, i checked my driver and it’s updated on the 29/10/2019 so last version, can’t do anything in-game due to crashes


#38

newest nvidia driver from 29th october fixed it for me.


#39

Same here, Just freeze everytime i try to build a construction. I have all drivers updated. My computer has RTX2070 and Ryzen 2800X. I’m trying to playin 2k resolution, all high.


#40

Hi. Before launching the game I downloaded the latest Radeon (19.9.2) driver and the game still crashed the PC every time a match started. Someone in the chats suggested to lower Shadows. I set it to zero and now it works. It looks like it still has issues though. I hope by release it will be as polished as it should be by Blizzard standard (SC2 always ran like a dream)


#41

Try this, set Shadows to zero. Worked for me so far.


#42

Exactly the same problem i’m having here