How to change the Gamma settings?


#1

Hello,
after updating the game to the latest version (1.31), I can not change the “Gamma” settings (brightness).
Previously, it was possible by adding the “-nativefullscr” flag when the game started, now even this option does not work.
Unfortunately, with such a dark screen the game is completely unplayable.


#2

There’s some new commands listed in the Patch sticky above by Pete Stillwell.

I’ve tried all of them and also cannot change gamma anymore. Older laptop running Win 7.

I can still change resolution.


#3
  • Removed: -nativefullscr (Replacement: -windowmode fullscreen)

It’s from the patch note, check them for full details.
I’m not sure about gamma setting tho, i never changed anything before.


#4

Ive got the same problem, even with the -windowmode fullscreen, tried on warcraft iii.exe x86 and x86_64. I cannot change gamma in both. :frowning:


#5

You need to use Direct3D 9 instead of 11. check patch notes

Sadly they might remove it in the future.


#6

Unfortunately, none of these options allows me to change the brightness of the screen :frowning:


#7

Sadly they might remove it in the future.

I think the reason they didn’t remove it now yet, is due to the fact that they know some older pc still run better on it.

Hopefully they won’t remove it unless they are sure they can make their DD11 work with higher fps.


#8

-graphicsapi Direct3D9 works


#9

i was having same probem but this is what worked for me. So go to your program files warcraft folder and find the Warcraft application that allows you to launch without being prompted to launch/repair. create a shortcut from that icon and drag the newly created shortcut to your desktop while leaving the original in youre WC3 folder. Once its on desktop right click it and go to the Shortcut tab in your properties. THE SAME PLACE YOU USED -nativefullscr. now instead use -windowmode fullscreen -graphicsapi Direct 3D9. BOTH of them. once you load warcraft, go to OPTIONS > VIDEO > SET GAME TO FULLSCREEN. you should be able to adjust brightness again and reuse all your old settings


#10

Thank you, I confirm that the option below works:

Target: “C:\Program Files (x86)\Warcraft III\x86_64\Warcraft III.exe” -graphicsapi Direct3D9


#11

Fix does not work for me. Do I need direct X 9 as well?