Game update required please run installer again


#4

Hi Guys,

Same here, I downloaded W3 through the launcher, erased all previous files, but still I’m required to get an update. Run as admin does not work neither.

Appreciate help


#5

i can run it just fine.


#6

Do I need to install W3 reinforged in order to run W3 classic?


#7

running into the same issue. infuriating.

like just bought this game and the pre-order software doesn’t work. truly sucks.


#8

same here it sucks super bad


#9

SAME HERE… its dragging me crazy. I tried to download this client and do things correctly. From original link and its not working. 0/10 would buy again


#10

same annoying message - Game update required… and reinstall and so just does not help, the game just stop working after some time, so boring


#11

Blizzard recently slipped in the first signs of an upcoming W3R Beta, Likely these recent issues have to do with that. Give it a day and Blizzard will have it fixed, or atleast announce whats wrong.


#12

Same issue here…
Been looking to play this all week…


#13

SAME BROTHERS :disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved:


#14

Same thing for me, and I had the game installed for the past 3 months running just fine.
I think they’re going to launch the beta today.


#15

Same to me, but just if i login with the account. But if i use the RoC CD key it works fine.


#16

then that is likely why it works for me. i use cd-keys.


#17

Game is not working for people that bought reforged. Hope they fix it soon enough.


#18

Same problem. Hoping for a solution soon :frowning:


#19

Experiencing this too, and i just preordered reforged


#20

Try installing the PTR client and running it. You’ll be prompted to login to Bnet to verify you have Reforged and it will succeed. Exit out of the PTR client and run the Warcraft III client and it should work.


#21

Thanks! problem solved!


#22

What’s the difference between PTR and the WC3 Client


#23

Also adding a new user under family and others then add someone else to this PC and just add someone that you dont have the email for or no way to contact them as the options and then restart your computer - this helped me with my issue