Game unable to start

Battlenet asks to update game. But nothing happens when I click the update button. Reinstalling doesn’t seem to help either.

1 Like

Same here. It says ‘waiting on another update’. But nothing is happening.

Hey there,

I’m not sure if you’re both experiencing the same cause here. I do have two more general ideas that can help get the game patched up so you can both play. The first focuses on 2 folders the Battle.net application uses for patching and installing. If something is damaged, it can cause things to stall. I am assuming this is for Windows systems. If you have a Mac instead, reply back and we’ll share more appropriate steps.

The steps to try first are:
.
1) Close open Blizzard programs.
2) Press Ctrl+Shift+Esc to open the Task Manager.
3) Click the Processes tab.
4) If agent.exe is running-or Blizzard Update Agent in Windows 10-select it and click End Process.
5) Navigate to the folder containing the cache directory:
- Press Windows Key+R to open the Run dialogue.
- Type %ProgramData% into the Run field and press Enter.
6) If a Blizzard Entertainment folder exists in the directory, right-click it and select Delete.
7) If a Battle.net folder exists in the directory, right-click it and select Delete.
8) Restart the Battle.net desktop app.

  • Note you’ll need to locate the game folders when you restart.

If that doesn’t work, we’ll want to rule out any issues with the Bnet app by removing it and all the folders it uses. This way we ensure nothing related to the program is causing a problem:
.
1) Uninstall the application - https://battle.net/support/article/30304
2) Press Windows key + R and type in %temp%
3) Delete anything related to Blizzard or Battle.net
4) Do the same for %programdata%, %localappdata%, %appdata%
5) Reinstall the application! - https://battle.net/account/download/index.xml?show=bnetapp

I am experiencing the same problem as mentioned above. And i am playing on a Mac.

I am trying to update my client of Warcraft III to the latest version. My current game version is 1.32.9.16289. I’ve tried to make the client check for new updates, which has then run through. The client then tells me Warcraft III is playable. I launch the game and i get a message telling me to download the newest update into version 1.32.10.16785. I then try to download for the new patch. But once the blizzard client is done updating, my client is still at version 1.32.9.16289.
Besides this course of troubleshooting, i’ve also tried running a Scan & Repair of the game as well as reinstalling. Neither were able to resolve the issue.

Would very much appreciate help in regards to resolving this issue.