Game crashes without any warnings or messages

Hi, can you try thus switch
It will force the game to play on opengl insted of directx, so if there is any problem in the timing between the dedicated graphics memory and the shared one it wont crush. Some acceleration methods are so sensitive to timing conflict. Like acc.copy and move specially if object link list involved in it to defince some or all npcs and moving objects in any defined world.

It is a strange issue. I have a new Acer i7 16GB Ram RTX3070i which crashes in every single Dota game I play, in 5- 10 minutes, while my old MSI I7 8GB Ram GTX 1060 doesn’t crash at all. I have reinstalled several times the game.

So, the only solution to this problem is to fix it myself? I’m not exactly a tech person. I just figured the tech support would fix the problem with the game? FYI I haven’t changed the computer I’m using to play the game either. It just kicks me off.

I was only on the campaign for 18 seconds that time and kicked me off. Is this being fixed or not?

I too am experiencing random crashes sometimes with an error screen, sometimes without. All during the campaign. This is extremely frustrating.

here is my dxdiag paste, its too large for this window: ------------------System Information------------------ Time of this r -

1 Like

This problem is not so complicated, in fact, very simple is Warcraft server is too poor will often jump Ping, and then the game reported an error exit.

Also, the official ranking mode still has many bugs, when will we see the game updated again, please tell the majority of Warcraft 3 players an approximate time. I strongly suggest that the official close the LAN function, because none of the games now have a LAN function, because of this any one person as long as a server can build a self-service, is not conducive to the official money.

Ask your team to try to develop profitable features for Warcraft 3, such as hero skins. Let your bosses see the potential of Warcraft 3 so that they can give more resources to your team. This way you can develop and update the game better!

1 Like

Even playing campaign im getting kicked out of the game and got this code as an error.
Im using a new MSI Laptop without overclocking. GTX 3050 ti , I7.
Please Fix this!


Same problem, in the campaign

Did scan and some pair which were not found. Tried once again and today an error message doesn’t even bother to pop up.
playing campaign (3) frostmaust . Once enemy is attacking, I got kicked out of the game all the time.

Are we getting help to fix this problem? All of my friends are having the same problem!

I assume that DirectPlay is turned off, the .NET 3.5 Framework ( which includes the .NET 1.x-2.x Framework ) is not installed, VC++ / DirectX 9 Redistributables are not up to date, etc.

NOTE: Right-click on the following batch file after saving it, and click “Run as administrator”. You will have to manually run the DirectX 9.x Redist after cURL finishes downloading it.

Use Notepad to create this file on your desktop or another folder: Dependency_Auto_Updater.bat
sc config BITS start= delayed-auto
sc config EventLog start= auto
sc config UsoSvc start= auto
sc config wuauserv start= auto
net start BITS
net start EventLog
net start UsoSvc
net start wuauserv
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Set-ExecutionPolicy -ExecutionPolicy Bypass -Scope CurrentUser -Force}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Set-ExecutionPolicy -ExecutionPolicy Bypass -Scope LocalMachine -Force}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Set-PSReadLineOption -HistorySaveStyle SaveNothing -MaximumHistoryCount 1}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Write-Output 'Remove-Module PSReadline' | New-Item -Path $PROFILE -Type File -Force}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls13}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Install-PackageProvider -Name PowerShellGet -Scope AllUsers -Force}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Install-PackageProvider -Name NuGet -Scope AllUsers -Force}"
powershell -noprofile -ExecutionPolicy Bypass -Command "& {Install-PackageProvider -Name WinGet -Scope AllUsers -Force}"
DISM /Online /Enable-Feature /FeatureName:LegacyComponents
DISM /Online /Enable-Feature /FeatureName:DirectPlay
DISM /Online /Enable-Feature /FeatureName:NetFx3
REM NOTE: If the "Microsoft App Installer" doesn't install, then you have to go into the Microsoft Store ( App ) and hit the "Retry" button.
winget install 9NBLGGH4NNS1 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2005.x86 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2005.x64 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2008.x86 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2008.x64 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2010.x86 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2010.x64 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2012.x86 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2012.x64 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2013.x86 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2013.x64 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2015+.x86 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.VCRedist.2015+.x64 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.DotNet.Runtime.3_1 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.DotNet.Runtime.5 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.DotNet.Runtime.6 --silent --accept-package-agreements --accept-source-agreements
winget install Microsoft.DotNet.Runtime.Preview --silent --accept-package-agreements --accept-source-agreements
ECHO Creating Offline Installers on the Desktop... ( Press CTRL+C to End ) && PAUSE
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\DirectX_End_User_Runtimes"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2005_(VC++_8.0)_SP1"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2008_(VC++_9.0)_SP1"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2010_(VC++_10.0)_SP1"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2012_(VC++_11.0)_Update_4"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2013_(VC++_12.0)"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2015_2017_2019_2022"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\DirectX_End_User_Runtimes"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2008_(VC++_9.0)_SP1"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2010_(VC++_10.0)_SP1"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2012_(VC++_11.0)_Update_4"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2013_(VC++_12.0)"
MKDIR "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022"
curl --parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022\vc_redist.arm64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022\vc_redist.arm64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2015_2017_2019_2022\vc_redist.arm64.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022\vc_redist.x86.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022\vc_redist.x86.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2015_2017_2019_2022\vc_redist.x86.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022\vc_redist.x64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2015_2017_2019_2022\vc_redist.x64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2015_2017_2019_2022\vc_redist.x64.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2013_(VC++_12.0)\vcredist_x86.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2013_(VC++_12.0)\vcredist_x86.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2013_(VC++_12.0)\vcredist_x86.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2013_(VC++_12.0)\vcredist_x64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2013_(VC++_12.0)\vcredist_x64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2013_(VC++_12.0)\vcredist_x64.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2012_(VC++_11.0)_Update_4\vcredist_x86.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2012_(VC++_11.0)_Update_4\vcredist_x86.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2012_(VC++_11.0)_Update_4\vcredist_x86.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2012_(VC++_11.0)_Update_4\vcredist_x64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2012_(VC++_11.0)_Update_4\vcredist_x64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2012_(VC++_11.0)_Update_4\vcredist_x64.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2010_(VC++_10.0)_SP1\vcredist_x86.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2010_(VC++_10.0)_SP1\vcredist_x86.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2010_(VC++_10.0)_SP1\vcredist_x86.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2010_(VC++_10.0)_SP1\vcredist_x64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2010_(VC++_10.0)_SP1\vcredist_x64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2010_(VC++_10.0)_SP1\vcredist_x64.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2008_(VC++_9.0)_SP1\vcredist_x86.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2008_(VC++_9.0)_SP1\vcredist_x86.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2008_(VC++_9.0)_SP1\vcredist_x86.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2008_(VC++_9.0)_SP1\vcredist_x64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2008_(VC++_9.0)_SP1\vcredist_x64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2008_(VC++_9.0)_SP1\vcredist_x64.exe" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_x86.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_x86.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_x86.EXE" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_IA64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_IA64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_IA64.EXE" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_x64.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_x64.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\Visual_Studio_2005_(VC++_8.0)_SP1\vcredist_x64.EXE" --next ^
--parallel-immediate --progress-bar --ssl-no-revoke --ssl-reqd --tlsv1.3 -LZRA "" "" --etag-compare "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\DirectX_End_User_Runtimes\directx_Jun2010_redist.txt" --etag-save "%UserProfile%\Desktop\VC++_NET_Runtimes\ETag_Cache\DirectX_End_User_Runtimes\directx_Jun2010_redist.txt" -o "%UserProfile%\Desktop\VC++_NET_Runtimes\Downloads\DirectX_End_User_Runtimes\directx_Jun2010_redist.exe"

REM Microsoft Visual C++ Redistributable latest supported downloads -> 
REM Notes: Windows XP Support: -> 
REM Reset / Repair Apps:
REM Settings -> System -> Other troubleshooters -> Windows Store Apps (Run)
REM Settings -> System -> Other troubleshooters -> Windows Update (Run)

I am having the same issue here. It is very annoying.
There is no pattern for when the crashes happen.
Yesterday I could play two matches, today the game closes without warning 20-30 after I open the game.

NVIDIA Geforce GTX 1060 (Driver version 517.48)
Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz 2.81 GH
Windows 10 Home (Version: 22H2)
Laptop Model: predator g3-571

PLEASE fix it!! The game is UNPLAYABLE!

1 Like

It is your game’s problem, not our PC’s problem.
You’d better get clear of this before you do as customer support.


The game crashes for me as well since 3 updates ago, but last update today made it unplayable - can’t finish any online games almost (with 10 players). Imagine how I feel. Imagine how the other 9 feel. This is a game problem, or an update that made it unplayable for many of us.
Just ask for more money if you need it to keep the servers up and running! Don’t do updates that kill games that were at least working before (even though with bugs). If you don’t fix this (it’s getting really annoying) I will consider that you made it on purpose to stop a game that doesn’t give you more revenue and I will avoid other blizzard games, suggest to kids and others to avoid them as well.

You should already have all the info you need. I’ve been sending error reports when game crashes for months now via windows.

Windows 11, AMD Ryzen 5 5600X 6-Core Processor, 16,0 GB RAM, NVIDIA GeForce GT 1030
with latest driver. No other apps/games have this problem! No overclocking etc.

So please stop wasting our time, go to the devs. if you are not one of them and figure out what the issue is. Please. If you want some more debugging info from me let me know.

1 Like

My game is crashing regularly too. I ran a scan and repair that came up with no issues. My PC is running high end games without any crashes at all, other blizzard games I have are running with no issues either. I also tried turning off all non-compulsory background programs, but I don’t understand why this game is crashing so regularly. All modes of the game are having issues at the moment. Appreciate if anyone has a solution for it or if the devs can fix the problem. I tried to report the problem, but customer service seems to blame it on my PC instead.

Turn spell effects to low.

Thanks Arcict, your suggestion to turn the spell effects to low made the game not crash for a while now during games (the usual crash each time I exist the game with ALT+F4 is still there of course).
Blizzard should include a fix for this in a future update - as not many will read this advice I suspect.

PS1: NO, it still crashed today! It’s almost like someone kicks me (makes my game crash) on purpose sometimes - when I am a pain for the other team or after I die. Very weird. But it is a bug that NEEDS TO BE FIXED. How does the current game work? Is it possible for the host to kick me? Or am I connected to blizzard servers to avoid that?
PS2: I just added the -opengl command line param in bnet - wIII launch settings, and I also switched to classic Video instead of reforged (it seems to be a known fact among players that reforged graphics have plenty of memory leaks and should either be not used or at least a restart should be done after each game; let’s see if that helps with anything…)
PS3: ok first game after I did that I had a blank screen for 5 min when game started, then game was already over and I could not even hit menu end game and get out of the game! So many bugs.

I am playing the campaign again and I’m on the 4th mission of the Maev Shadowsong campaign, and the game keeps crashing and closing out as I reach the second naga dig site. The game has had 3 updates since this problem started with no changes.

1 Like

I m at the same campaign mission and the game is crashing all the time!!