Campaign Crashes

Constant crash in Human campaign chapter 6 “The Culling” in version Experiencing lag and low fps when navigating and selecting unit. Re-installed game and same issue. I am certain this issue did not exist in earlier versions.

1 Like

Same thing has been happening to myself and many others. Has been happening to me nonstop since March, and seems to be much worse with campaign missions, but happens in all game modes for me. I’ve spoken with support but was told that its a known bug but they don’t have a fix currently and are hoping for a fix “soon”. I wish they would speak out about it :frowning:

1 Like

Have you tried turning spell effects to low?

Reforged is such a dumpster fire. Campaign still crashes like crazy after all this time at this point id rather just have a refund.


You can still get one. The automated process will reject you, then file a ticket.


Double tapping the hotkey for Barracks or Town hall can cause a crash on this campaign save which our team is investigating. Some workarounds that can help:

  • Load the map fresh
  • Don’t use hotkeys.

Thank you.

I have tried loading the map fresh and went through without using any hotkeys and it still crashed, when I mouse selected the barracks.

Do you know if they were playing on a specific difficulty mode? There are triggers specific to certain structures on the map. I have not been able to reproduce this crash though.

Well it’s good to know i am not the only one with these issues. I dk how they could break something even worse so long after release. Well reforged has always had its issues, i never once had a crash until this started.

1 Like

i have done a few tests ive been saving my games sometimes it works without crashing by saving in the ingame menu but it has failed me my new thing that seemed to work only possible chance not confirmed getting off for the night because i failed the campaign on hard i ran out of gold trying to take silvermoon on hard but regardless i will bullet point what has worked kinda and not so far

  1. Saved game a few times in the missions seems to only work sometimes
  2. Opened warcraft 3 twice and closed the first window i opened was able to play a saved file that crashed when i tried to do it before opening 2 windows by accident.

if it works for you just reply so people can see it works so we can just play the game

There are also frequent crash in Undead campaign chapter 5 “The Fall of Silvermoon”. I think the work around now is to avoid group and hotkey the building and just use mouse to select barracks and it let me finish without crashing. However, I think this still needs to be fixed in the next patch.

I’ve gotten the same issue and so do my mate. Constant crashing. To be honest, this constant error on a simple game stops me purchase other games. Cannot use money on games that crashed all the time, life is to short for that waste of time. Fix it or sell Blizzard to a company that actually can make games.

1 Like

Happening here too in Wrath of the betrayer. The response to my ticket was to try reinstallation, and that seems to have done nothing.

1 Like

Turn spell effects to low.

It is already set to low. Everything in video option has been set to low.

i have the same issue,in reforge, on campaigns,it’s crashing a lot , when blizzards will do something? Do i have to save the game every 1 minutes? to get back were i left, just for a small advance in missions? :pensive: :pensive:. i love this game.:cry:

The team working on WC and SC left to Dreamhaven, GG

Campaign always crashes to desktop whenever I play the Undead Campaign and I reach the Quel’thalas missions. Normally it only happens during the Fall of Silvermoon, and now its happening with the mission Into the Realm Eternal as well.

Still crashing for me on mission 4 of sentinal (wrath of betrayer)


Same issue here, game worked fine till this Sentinel mission 4: Wrath of the Betrayer. Always crashes, and to reproduce this, for me its crashing whenever i move fast on the map with cursor.

A hotfix would be nice, since this issue is present for some time now and is preventing players from playing the game… Or is the Warcraft 3 team completely dead ?